Samba problem after 7.05.2018 update

samba

#36

No, that [HOMES] config I put in there is for allowing users to share from within their own home directories, provided they set them up properly.

Make sure that you have not changed the owner or permission for any other folders under /var/lib/samba/ or for /var/lib/samba/ itself. They should all be 755 except usershare.

Also have you tried logging into samba using your credentials first?

I don’t usually use samba at home, but I’ll check at the office tomorrow morning.

PS, Samba has always been a PITA TBH… I switched to using nfs at home years ago, but then I haven’t run windows in my home since 1998…


#37

Hey guys, I just had a thought. I’m not sure, but I think I read somewhere that the last update had introduced a bug in Pam. Is it possible that might be interfering with authentication.


#38

If you can find the link to that, it would be helpful.


#39

I’ll try. It’s just that I read so many links in a day it might be like trying to find a needle in a haystack.


#40

So is that issue reproducible for others? It would be good to know if I messed something or is it more general problem.

It’s more complicated then that in my case but I think it’s correct. Here are my permissions:

Of course /var/lib/samba/ is 755.


#41

Haven’t been able to find the bug report yet, but I did find this in the last update notice. I hope that is of some assistance @AJSlye

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn ‘pam_unix[2_]’ /etc/pam.d, if no output, you need to do nothing.

https://forum.manjaro.org/t/stable-update-2018-05-07-kernels-mesa-glibc-php-nvidia-plasma5-firefox/46632/2


#43

Yup, just a slight change.


#44

Never mind…
I don’t think pam has anything to do with this issue.


#45

I had trouble creating shares from File manager on MATE with Samba 4.8.X. I couldn’t create any share at all with Caja. Had something like : “Error 255 cannot convert name “Everyone” to a SID”.

I could solve it first by removing the smb.conf completely, then reconfigure a fresh new smb.conf with required options for usershares.

Then, someone else found out that simply commenting group = sambashare with a # worked for him (or removing the line completely, though I would first try to comment it in case it doesn’t work). Verified on my system, and it worked perfectly on my system too: could create shares as I wished with Caja again.

You could give it a shot. If it doesnt work, well you put the line back by removing the #.

Don’t forget to reset smb and nmb services so changes in smb.conf takes effect (or reboot your computer if you wish).


Samba share working but not browsable by Manjaro Xfce [Broken again]
#46

I think that line should have been force group = sambashare.
Me thinks a typo you found. Bin bada bad, LOL…

https://wiki.samba.org/index.php/Setting_up_Samba_as_https://wiki.samba.org/index.php/Setting_up_Samba_as_a_Standalone_Server#Advanced_share_settingsa_Standalone_Server#Advanced_share_settings


#47

Doesn’t work for me. I really have to comment/remove this line in order to be able to create shares from Caja.

Not that suprising since group and force group are considered synonym according to manual of smb.conf.
https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html#FORCEGROUP

I’ll just keep it commented.


#48

Quote from the wiki:

The force create mode and force directory mode parameters force Samba to create new files and folders with the set permissions.

The force user and force group parameters map all connections to the specified user and group. Note that this can cause security problems if all users connecting to a share are mapped to a specific user account or group in the background.

Are you sure your in the sambashare group?
If yes, then something must have changed in the last update.
Could be a bug, could also be a deliberate change, I’ll investigate.


#49

OK, I just tested this on my Netrunner Rolling box and force group = sambashare works fine.
I’m using the default settings and correct folder permissions in my package.

@Frog,
Did you stop and start the services smb and/or nmb after making the change?
Could some other settings or permission you performed be causing your issue?
(aka /var/lib/samba/usershare doesn’t belong to the sambashare group, etc.)

sudo chgrp sambashare var/lib/samba/usershare

Is your home directory is accessible by the smb client proccess?


#50

Info, the # group = sambashare solve my problem too :slight_smile:

sudo systemctl restart smb nmb

And I could share folders.

Deepin with nemo.


#51

I changed this line to force group = sambashare in my smb,conf file and it’s working as well.
Does your smb.conf look the same as mine?:


#52
[global]
   workgroup = WORKGROUP
   dns proxy = no
   log file = /var/log/samba/%m.log
   max log size = 1000
   client max protocol = NT1
   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
   pam password change = yes
   map to guest = bad password
   usershare allow guests = yes
   name resolve order = lmhosts bcast host wins
   security = user
   guest account = nobody
   usershare path = /var/lib/samba/usershare
   usershare max shares = 100
   usershare owner only = yes
   #  group = sambashare
   force create mode = 0070
   force directory mode = 0070
   name resolve order = lmhosts bcast host wins

[homes]
   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0700
   directory mask = 0700
   valid users = %S

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no


#53

map to guest = Bad Password is missing


#54
wrong map to guest = bad password
right  map to guest = Bad Password

??


#55

I’m going over it, yours is a bit out of order, hard to compare in a web browser.


#56

I am tired sorry :wink:

Double “name resolve order = lmhosts bcast host wins” inside, I try some hours, and in many tutorials they wrote usershares not usershare, I got crazy from that stuff :smiley: