Samba keeps adding username to the address

#1

Hi All,

I recently switched to Manjaro from Linux Mint. I am not a Linux power user, its only been about 5 months since I switched full time to Linux. I have digged around the forum as much as i can and could not find an answer.

I am trying to connect to a public windows shared location in my office. It was quite simple in Linux Mint. I would just type "smb://srlkpub/pub/" in Nemo address bar, then it will prompt to enter my username and password and im in.

However I was trying to do the same in Manjaro and it kept saying my password is wrong. It switched back to Mint and tested the same credentials which worked without trouble. After close inspection i noticed the error message dolphin is giving. It says "Access denied to smb://ranjana@srlkpub/pub". It is adding the username to the url. I checked with my MIS folks who said the url is wrong when my username is in the middle like that. IS there a way I can stop Manjaro doing this? Or am I not understanding something?

A quick response is much appreciated. This issue could be a deal breaker for me and could force me back to Mint as my office workflow depends on flies shared in this server.

Thanks in Advance

0 Likes

#2

Maybe start here:

These directions are marked as out of date but, I use them to set up samba on my xfce installs without issue (using the auto configuration package):
https://wiki.manjaro.org/index.php?title=Using_Samba_in_your_File_Manager

0 Likes

#3

In the link you shared. it says
"KDE has the ability to browse shares built-in". I believe that's exactly what i am trying to do and failing. Do I have to configure even just to browse a shared folder?

0 Likes

#4

Btw, I followed the steps in the links you shared. But the problem persists. Behavior is still the same

0 Likes

#5

On our home network to see W10 shared files we have added the W10 pc's user to the smb group (sudo smbpasswd -a username) after they get added to each manjaro pc's user account(administrator) using the same name and password they log into their w10 pc with to solve the authentication issue.
They appear in dolphin-network-smb-workgroup-the w10 pc- file.
The smb,config file obtained when ' manjaro-settings-samba' is installed is properly configured?

0 Likes

#6

I believe that format is correct on the dolphin side and it gets parsed and re-assembled before it hits the other side.

Is your username different in the windows environment? If so, try putting your Windows username in the url.

0 Likes

#7

Nope. Usernames are exactly the same

0 Likes

#8

Sorry if this is a naive question, what exactly needs to be changed in the smb config file? I didnt do any changes to that.

0 Likes

#9

what exactly needs to be changed in the smb config file?

The name of the workgroup if not the same.

What else? I copy my config file from one machine to another so I'm not sure what has actually changed here is my global settings -
[global]
workgroup = BASE5
dns proxy = no
log file = /var/log/samba/%m.log
max log size = 1000
client max protocol = NT1
server role = standalone server
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = NewUNIXpassword %n\n ReTypenewUNIXpassword* %n\n passwd:allauthenticationtokensupdatedsuccessfully*
pam password change = yes
map to guest = Bad Password
usershare allow guests = yes
name resolve order = lmhosts bcast host wins
security = user
guest account = nobody
usershare path = /var/lib/samba/usershare
usershare max shares = 100
usershare owner only = yes
force create mode = 0070
force directory mode = 0070

Shares-
[kidsmovies$]
comment = kidsmovies
path = /run/media/store/KidsMovies/
browseable = yes
read only = no
guest ok = yes
create mask = 0750

[kidsmovies]
comment = kidsmovies
path = /run/media/store/KidsMovies/
browseable = yes
read only = no
guest ok = yes
create mask = 0770

0 Likes