Samba Gehversuch gelingt nur teilweise

Auf meinem PC mit hostname lapis (IP Adr 192.168.1.113) habe ich mit Manjaro Architect ein CLI System installiert. Als erstes will ich die Netzwerkfähigkeit erkunden.

Auf lapis sehe ich:

(1) ping -c3 www.manjaro.org liefert Antwort von 176.9.38.148. Das ist OK.

(2) ping -c3 achat (achat heißt mein zweiter PC, IP adresse über wlan 192.168.1.105) liefert Antwort von achat.fritz.box. Ich weiß nicht, wie ich das interpretieren soll. achat.fritz.box ist doch etwas anderes als achat, oder?

(3) ping -c3 192.168.1.105 liefert 3x: 64 bytes from 192.168.1.105 …

Umgekehrt sehe ich auf achat:

(4) ping -c3 lapis: liefert 3x
PING lapis(lapis.fritz.box (2001:a61:2b2a:5f01:40f8:8704:2217:4d03)) 56 data bytes
Von achat.fritz.box (2001:a61:2b2a:5f01:7f6d:41a:5377:dd72) icmp_seq=1
Ziel nicht erreichbar: Adresse nicht erreichbar

(5) ping -c3 192.168.1.113: liefert aber 3x
64 Bytes von 192.168.1.113: …

Meine Folgerung: In meinem Heimnetz besteht Verbindung - mit wesentlicher Einschränkung, weil der andere PC nicht über seinen host-Namen erreichbar ist.

Deshalb Frage A: was fehlt hier noch, damit (2) und (4) das gewünschte Egebnis (3) bzw (5) liefern?

Samba - von achat nach lapis

Als nächstes habe ich auf lapis/Manjaro samba installiert, mit “net usershare add jaroall …” einen Ordner freigegeben. Den kann ich von achat/thunar aus wie folgt sehen.

Ich tippe ins Adressfeld

smb://jaro@192.168.1.113/jaroall
oder 
smb://jaro@lapis/jaroall,

werde aufgefordert, ein Passwort einzugeben und bin am Ziel.

Eigentlich sollte ich den freigegebenen Ordner in thunar über “Netzwerk durchsuchen” sehen, anklicken, Passwort eingeben.

Frage B: Warum geht das Eigentliche nicht? Was fehlt noch?

Samba - von lapis nach achat

Auf achat habe ich mit “net usershare add achat-jaro …” einen Ordner freigegeben. Der sollte nun in analoger Weise von lapis/Manjaro aus sichtbar sein. lapis/Manjaro ist bisher ein CLI-System; mein einziger file Manager ist dort der Midnight Commander (mc). Das mc-Befehls-Menü hat eine Funktion “SMB link”. Doch damit laufe ich immer wieder auf den Fehler

"Cannot chdir to “/smb://achat.fritz.box” bzw "Cannot chdir to “/smb://192.168.1.104”.

Frage C: Vielleicht kann ich auf lapis die Samba-Verbindung auf andere Weise testen? Was lässt sich noch per Kommando aufrufen? (Ich habe ja noch keine Grafik und deswegen noch kein thunar.)

Hallo Thomas,
kann dir nur ein paar Anmerkungen bieten, keine Lösung. Was mir eben so aufgefallen ist:

genau kannst eigentlich nur Du das beantworten, denn Du hast deine Kinder benannt. Aber da die IP-Adresse stimmt, ist es ja wohl der gleiche Rechner, achat ist eben der Hostname und achat.fritz.box der voll qualifizierte Name (FQDN). Das ist in etwa wie nur Vorname und Vorname + Familienname.

hier fällt mir auf, dass ping plötzlich nur IPv6 spricht (es sei denn, Du hast IPv4 weggelassen). Also könnte die Nicht-Erreichbarkeit auch nur daran liegen, dass lapis schlicht kein IPv6 versteht, weil es im Netzwerkmanager nicht eingestellt ist. Du könntest es also mit der Option -4 bei ping nochmal versuchen.
Allerdings ist mir unklar, warum ping nur IPv6 verlangen sollte.
Fazit: deine Einschätzung

teile ich so 100%-ig nicht. Frage A könnte also mit
“bring lapis IPv6 bei”
beantwortet werden. Bitte beachte den Konjunktiv “könnte” :wink:
Zu mc habe ich mal gelesen, dass dies gute alte Teil bei Samba nur IP-Adressen versteht. Keine Ahnung, ob das noch zutrifft, mein mc kann nicht mal Samba. Apropos mc und IP-Adressen, das hier

ist doch wohl nur ein Typo, war die Adresse nicht eigentlich 192.168.1.105?

z.B.
testparm
um zu sehen, ob deine smb.conf formal in Ordnung ist
und
smbclient -L 192.168.1.105
überhaupt smbclient. Lies bitte mal
man smbclient
da erfährst Du noch mehr Möglichkeiten.

viele Grüße gosia