Run into pacman-issues during the upgrde process: Ungültiges oder beschädigtes Paket (PGP-Signatur)

run into pacman issues during the upgrade of manjaro - linux

see more details:

`1` `:: Datei /var/cache/pacman/pkg/qt5-quickcontrols-5.12.1-2-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`2` `Soll die Datei entfernt werden? [J/n] j`

`3` `Fehler: kirigami2: signature from ` `"Antonio Rojas <arojas@archlinux.org>"` `is invalid`

`4` `:: Datei /var/cache/pacman/pkg/kirigami2-5.56.0-2-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`5` `Soll die Datei entfernt werden? [J/n] `

see more details:

`01` `python-pip-18.1-2-any    251,5 KiB  1676K/s 00:00 [` `###################] 100%`

`02` ` ` `rubygems-3.0.3-1-any     220,7 KiB   655K/s 00:00 [` `###################] 100%`

`03` ` ` `xorg-server-common-...    27,0 KiB   290K/s 00:00 [` `###################] 100%`

`04` ` ` `xorg-server-1.20.4-...  1273,9 KiB  1151K/s 00:01 [` `###################] 100%`

`05` ` ` `sddm-kcm-5.15.2-1-x...   103,8 KiB   367K/s 00:00 [` `###################] 100%`

`06` ` ` `spectacle-18.12.3-1...  1210,4 KiB  1161K/s 00:01 [` `###################] 100%`

`07` ` ` `srt-1.3.2-1-x86_64       680,7 KiB  1022K/s 00:01 [` `###################] 100%`

`08` ` ` `thunderbird-60.5.3-...    34,3 MiB  1475K/s 00:24 [` `###################] 100%`

`09` ` ` `user-manager-5.15.2...   414,7 KiB   846K/s 00:00 [` `###################] 100%`

`10` ` ` `vulkan-icd-loader-1...    95,5 KiB   463K/s 00:00 [` `###################] 100%`

`11` ` ` `vlc-3.0.6-8-x86_64        10,7 MiB  1445K/s 00:08 [` `###################] 100%`

`12` ` ` `vulkan-intel-18.3.4...   977,4 KiB  1137K/s 00:01 [` `###################] 100%`

`13` ` ` `vulkan-radeon-18.3....   700,3 KiB  1567K/s 00:00 [` `###################] 100%`

`14` ` ` `webkit2gtk-2.22.7-1...    25,7 MiB  1456K/s 00:18 [` `###################] 100%`

`15` ` ` `xf86-video-amdgpu-1...    66,0 KiB   348K/s 00:00 [` `###################] 100%`

`16` ` ` `xf86-video-ati-1:19...   148,4 KiB  1207K/s 00:00 [` `###################] 100%`

`17` ` ` `xf86-video-intel-1:...   671,5 KiB  1056K/s 00:01 [` `###################] 100%`

`18` ` ` `xorg-xinit-1.4.1-1-...    17,0 KiB   243K/s 00:00 [` `###################] 100%`

`19` ` ` `ttf-liberation-2.00...  1421,3 KiB  1533K/s 00:01 [` `###################] 100%`

`20` ` ` `cpupower-5.0-1-x86_64    137,6 KiB   463K/s 00:00 [` `###################] 100%`

`21` ` ` `filezilla-3.41.1-1-...     4,0 MiB  1267K/s 00:03 [` `###################] 100%`

`22` ` ` `libnfs-4.0.0-3-x86_64    128,2 KiB   470K/s 00:00 [` `###################] 100%`

`23` ` ` `inxi-3.0.32-1-any        171,4 KiB   558K/s 00:00 [` `###################] 100%`

`24` ` ` `python-progress-1.5...    11,5 KiB  0,00B/s 00:00 [` `###################] 100%`

`25` ` ` `qtermwidget-0.14.1-...   193,4 KiB   542K/s 00:00 [` `###################] 100%`

`26` ` ` `sshfs-3.5.1-2-x86_64      31,5 KiB  1577K/s 00:00 [` `###################] 100%`

`27` ` ` `lib32-libelf-0.176-...   381,8 KiB   743K/s 00:01 [` `###################] 100%`

`28` ` ` `lib32-libva-mesa-dr...  2017,0 KiB  1247K/s 00:02 [` `###################] 100%`

`29` ` ` `lib32-libvdpau-1.2-...    20,8 KiB   297K/s 00:00 [` `###################] 100%`

`30` ` ` `lib32-mesa-18.3.4-1...    12,4 MiB  1479K/s 00:09 [` `###################] 100%`

`31` ` ` `lib32-mesa-vdpau-18...     2,1 MiB  1320K/s 00:02 [` `###################] 100%`

`32` ` ` `lib32-systemd-241.6...   411,2 KiB   851K/s 00:00 [` `###################] 100%`

`33` ` ` `lib32-vulkan-intel-...  1086,9 KiB  1181K/s 00:01 [` `###################] 100%`

`34` ` ` `lib32-vulkan-radeon...   758,3 KiB  1064K/s 00:01 [` `###################] 100%`

`35` `(247/247) Prüfe Schlüssel im Schlüsselring         [` `###################] 100%`

`36` `(247/247) Überprüfe Paket-Integrität               [` `###################] 100%`

`37` `Fehler: qt5-quickcontrols: signature from ` `"Antonio Rojas <arojas@archlinux.org>"` `is invalid`

`38` `:: Datei /var/cache/pacman/pkg/qt5-quickcontrols-5.12.1-2-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`39` `Soll die Datei entfernt werden? [J/n] j`

`40` `Fehler: kirigami2: signature from ` `"Antonio Rojas <arojas@archlinux.org>"` `is invalid`

`41` `:: Datei /var/cache/pacman/pkg/kirigami2-5.56.0-2-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`42` `Soll die Datei entfernt werden? [J/n] n`

`43` `Fehler: plasma-framework: signature from ` `"Antonio Rojas <arojas@archlinux.org>"` `is invalid`

`44` `:: Datei /var/cache/pacman/pkg/plasma-framework-5.56.0-2-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`45` `Soll die Datei entfernt werden? [J/n] n`

`46` `Fehler: krunner: signature from ` `"Antonio Rojas <arojas@archlinux.org>"` `is invalid`

`47` `:: Datei /var/cache/pacman/pkg/krunner-5.56.0-1-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`48` `Soll die Datei entfernt werden? [J/n] j`

`49` `Fehler: milou: signature from ` `"Antonio Rojas <arojas@archlinux.org>"` `is invalid`

`50` `:: Datei /var/cache/pacman/pkg/milou-5.15.2-1-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`51` `Soll die Datei entfernt werden? [J/n] j`

`52` `Fehler: kscreenlocker: signature from ` `"Antonio Rojas <arojas@archlinux.org>"` `is invalid`

`53` `:: Datei /var/cache/pacman/pkg/kscreenlocker-5.15.2-1-x86_64.pkg.` `tar` `.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).`

`54` `Soll die Datei entfernt werden? [J/n] `

what can i do now!?

I can’t read what that says exactly but have you tried refreshing/updating your keyring as described in this post:

https://forum.manjaro.org/t/issues-with-signature-is-marginal-trust-or-invalid-or-corrupted-package/

2 Likes

It could be as simple as your computers clock which maybe off due to a CMOS battery fault.

hello dear Dalto hello dear fldk
many thanks _ i will try out the keyring - things.

many many thanks for all your help - i am loving this forums here.

greetings

update - see what i have gained - some more insights

Passwort: 
[martin-pc martin]# pacman -Scc
Fehler: Konnte den Vorgang nicht starten (Kann Datenbank nicht sperren)
Fehler: Konnte Datenbank nicht sperren: Die Datei existiert bereits
  Wenn Sie sicher sind, dass nicht bereits ein
  Paketmanager läuft, können Sie /var/lib/pacman/db.lck entfernen
[martin-pc martin]# pacman -Syy
:: Synchronisiere Paketdatenbanken...
Fehler: Konnte core nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Konnte extra nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Konnte community nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Konnte multilib nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Fehler beim synchronisieren aller Datenbanken
[martin-pc martin]# pacman -Syu
:: Synchronisiere Paketdatenbanken...
Fehler: Konnte core nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Konnte extra nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Konnte community nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Konnte multilib nicht aktualisieren (Kann Datenbank nicht sperren)
Fehler: Fehler beim synchronisieren aller Datenbanken
[martin-pc martin]#

hello dear experts - did everything to get the sytem fixed - but i guess that i failed…


pg: Anzahl insgesamt bearbeiteter Schlüssel: 130
gpg:                             unverändert: 70
gpg:                           neue User-IDs: 3
gpg:                         neue Signaturen: 923
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: Tiefe: 0  gültig:   1  signiert:  23  Vertrauen: 0-, 0q, 0n, 0m, 0f, 1u
gpg: Tiefe: 1  gültig:  23  signiert:  84  Vertrauen: 0-, 0q, 0n, 23m, 0f, 0u
gpg: Tiefe: 2  gültig:  75  signiert:  14  Vertrauen: 75-, 0q, 0n, 0m, 0f, 0u
gpg: nächste "Trust-DB"-Pflichtüberprüfung am 2019-05-10
[martin-pc martin]#

If you’re getting an error similar to “Can’t update: signature from *** is marginal trust” or “invalid or corrupted package” you probably just need to update your package signing keys:

sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

If one fails, try the next then retry, and once all succeed retry the update.
Of course, it’s also possible that the package file actually is corrupt. Remove it from /var/cache/pacman/pkg so pacman will download it again. If this still don’t work, read the rest of this thread: Issues with "signature is marginal trust" or "invalid or corrupted package"



Gesamtgröße des Downloads:              4,98 MiB
Gesamtgröße der installierten Pakete:  2737,77 MiB
Größendifferenz der Aktualisierung:    22,30 MiB

:: Installation fortsetzen? [J/n] j
:: Empfange Pakete...
Fehler: Konnte Datei 'kirigami2-5.56.0-2-x86_64.pkg.tar.xz' nicht von mirror.deace.id übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'kirigami2-5.56.0-2-x86_64.pkg.tar.xz' nicht von manjaro.moson.eu übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'kirigami2-5.56.0-2-x86_64.pkg.tar.xz' nicht von mirror.futureweb.be übertragen : The requested URL returned error: 404
 kirigami2-5.56.0-2-...   274,1 KiB   923K/s 00:00 [###################] 100%
Fehler: Konnte Datei 'plasma-framework-5.56.0-2-x86_64.pkg.tar.xz' nicht von mirror.deace.id übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'plasma-framework-5.56.0-2-x86_64.pkg.tar.xz' nicht von manjaro.moson.eu übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'plasma-framework-5.56.0-2-x86_64.pkg.tar.xz' nicht von mirror.futureweb.be übertragen : The requested URL returned error: 404
 plasma-framework-5....     4,5 MiB   245K/s 00:19 [###################] 100%
Fehler: Konnte Datei 'kscreenlocker-5.15.2-1-x86_64.pkg.tar.xz' nicht von mirror.deace.id übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'kscreenlocker-5.15.2-1-x86_64.pkg.tar.xz' nicht von manjaro.moson.eu übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'kscreenlocker-5.15.2-1-x86_64.pkg.tar.xz' nicht von mirror.futureweb.be übertragen : The requested URL returned error: 404
 kscreenlocker-5.15....   176,9 KiB   288K/s 00:01 [###################] 100%
(247/247) Prüfe Schlüssel im Schlüsselring         [###################] 100%
(247/247) Überprüfe Paket-Integrität               [###################] 100%
Fehler: kwin: signature from "Antonio Rojas <arojas@archlinux.org>" is invalid
:: Datei /var/cache/pacman/pkg/kwin-5.15.2-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: qqc2-desktop-style: signature from "Antonio Rojas <arojas@archlinux.org>" is invalid
:: Datei /var/cache/pacman/pkg/qqc2-desktop-style-5.56.0-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: plasma-integration: signature from "Antonio Rojas <arojas@archlinux.org>" is invalid
:: Datei /var/cache/pacman/pkg/plasma-integration-5.15.2-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Drücken Sie eine beliebige Taste um fortzufahren...

Your package database is out-of-date.

Update your mirror list and update again.

And refresh/repopulate your keyring again.

Also check your system clock is correct.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.