Run from desktop instead of terminal

I am running Manjaro with the MATE desktop on a RPi4-8G.
I have problems with LibreOffice Calc (V7.2.4.1). It runs very slowly with large spreadsheets. I found a solution on a Ubuntu forum, which involves running the following line from the terminal:
SAL_USE_VCLPLUGIN=gen libreoffice
The program works much faster, but has a less attactive “skin”.
How can I launch this libreoffice without using the terminal? I tried changing the “exec=” line in libreoffice-calc.desktop (in /usr/share/applications), but this did not work.
Thanks in advance for any assistance.

make a libreoffice-fast.desktop file and add these contents :point_down:

[Desktop Entry]
Version=1.0
Name=libreoffice-fast
Exec=sh -c 'SAL_USE_VCLPLUGIN=gen libreoffice'
Icon=libreoffice
Terminal=true
Type=Application

keep this file in /usr/share/applications

You have a number of options.

The first I would probably do is what you mentioned, but I will outline how I would do it:

cp /usr/share/applications/libreoffice-calc.desktop ~/.local/share/applications/

Then edit the new desktop file in your HOME ;

nano ~/.local/share/applications/libreoffice-calc.desktop

So it should look like this (note there are 2 Exec lines)

[Desktop Entry]
Version=1.0
Terminal=false
Icon=libreoffice-calc
Type=Application
Categories=Office;Spreadsheet;X-Red-Hat-Base;X-MandrivaLinux-Office-Spreadsheets;
Exec=/usr/bin/sh -c "SAL_USE_VCLPLUGIN=gen libreoffice --calc %U"
MimeType=application/vnd.oasis.opendocument.spreadsheet;application/vnd.oasis.opendocument.spreadsheet-template;application/vnd.sun.xml.calc;application/vnd.sun.xml.calc.template;application/msexcel;application/vnd.ms-excel;application/vnd.openxmlformats-officedocument.spreadsheetml.sheet;application/vnd.ms-excel.sheet.macroEnabled.12;application/vnd.openxmlformats-officedocument.spreadsheetml.template;application/vnd.ms-excel.template.macroEnabled.12;application/vnd.ms-excel.sheet.binary.macroEnabled.12;text/csv;application/x-dbf;text/spreadsheet;application/csv;application/excel;application/tab-separated-values;application/vnd.lotus-1-2-3;application/vnd.oasis.opendocument.chart;application/vnd.oasis.opendocument.chart-template;application/x-dbase;application/x-dos_ms_excel;application/x-excel;application/x-msexcel;application/x-ms-excel;application/x-quattropro;application/x-123;text/comma-separated-values;text/tab-separated-values;text/x-comma-separated-values;text/x-csv;application/vnd.oasis.opendocument.spreadsheet-flat-xml;application/vnd.ms-works;application/clarisworks;application/x-iwork-numbers-sffnumbers;application/x-starcalc;
Name=LibreOffice Calc
GenericName=Spreadsheet
GenericName[en]=Spreadsheet
Comment=Perform calculations, analyze information and manage lists in spreadsheets by using Calc.
Comment[en]=Perform calculations, analyze information and manage lists in spreadsheets by using Calc.
StartupNotify=true
X-GIO-NoFuse=true
Keywords=Accounting;Stats;OpenDocument Spreadsheet;Chart;Microsoft Excel;Microsoft Works;OpenOffice Calc;ods;xls;xlsx;
InitialPreference=5
StartupWMClass=libreoffice-calc
X-KDE-Protocols=file,http,ftp,webdav,webdavs

Actions=NewDocument;
[Desktop Action NewDocument]
Name=New Spreadsheet
Name[en]=New Spreadsheet
Icon=document-new
Exec=/usr/bin/sh -c "SAL_USE_VCLPLUGIN=gen libreoffice --calc"

@archbtw aw. You just beat me :speedboat:
But … in desktop files full paths should be used :wink: (sh -c)
Also HOME is probably a better place than system directory.

2 Likes

Thank you for the solution, which works well.
When running LibreOffice Calc this way, the user interface looks like Windows c. 1995, but the performance is superb. Instead of a second or so lag when moving from cell to cell, there is no perceptable lag at all. I’ll live with the “nostalgic” user interface.

It pre-empts the move you want to make and go there by itself? The opposite of lag.


Just couldn’t help myself. :wink:

Cheers.

Another thing that tends to boost LibreOffice performance is
Tools > Options > LibreOffice > Advanced > Use a Java runtime environment [uncheck]

Another thing that tends to boost LibreOffice performance is
Tools > Options > LibreOffice > Advanced > Use a Java runtime environment [uncheck]

I tried that, but it didn’t make any noticeable difference.

It pre-empts the move you want to make and go there by itself? The opposite of lag.

Sort of what happens when you keep your finger pressed on the arrow key for too long.

EXACTLY!!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.