Ruhezustand/Bereitschaft wacht wieder auf


#1

Hallo,
mein Rechner macht seit Kernel. 4.14 kein Ruhezustand oder Bereitschaft mehr. Mit Kernel 4.9. geht alles wunderbar.
Was kann ich denn da machen bzw. wo ansetzen?
Nach Ruhezustand wacht er nach 5 sec. wieder auf.
Grüße Flo


#2

Moved to Kernel und Hardware in the German section.


#3

:+1: Danke


#4

kein Problem


#5

Weiß keiner rat?


#6

Similar (but in English):

If my use of Google translate is good enough :smiley:


#7

where is the code for the logfile where i can see the problem? i have a desktop machine with core i7… the only message where i can find is “cpu can not sleep”…
i hope my english is good enough:-)


#8

[ 54.100925] Suspending console(s) (use no_console_suspend to debug)
[ 54.101124] sd 1:0:0:0: [sdb] Synchronizing SCSI cache
[ 54.101209] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 54.101384] sd 1:0:0:0: [sdb] Stopping disk
[ 54.103710] sd 0:0:0:0: [sda] Stopping disk
[ 54.666422] ACPI: Preparing to enter system sleep state S3
[ 54.666682] PM: Saving platform NVS memory
[ 54.666729] Disabling non-boot CPUs …
[ 54.694038] smpboot: CPU 1 is now offline
[ 54.714072] smpboot: CPU 2 is now offline
[ 54.747416] smpboot: CPU 3 is now offline
[ 54.767946] smpboot: CPU 4 is now offline
[ 54.797387] smpboot: CPU 5 is now offline
[ 54.827377] smpboot: CPU 6 is now offline
[ 54.854031] smpboot: CPU 7 is now offline
[ 54.855591] ACPI: Low-level resume complete
[ 54.855632] PM: Restoring platform NVS memory
[ 54.856454] Enabling non-boot CPUs …
[ 54.856488] x86: Booting SMP configuration:
[ 54.856489] smpboot: Booting Node 0 Processor 1 APIC 0x2
[ 54.859237] cache: parent cpu1 should not be sleeping
[ 54.859391] CPU1 is up
[ 54.859412] smpboot: Booting Node 0 Processor 2 APIC 0x4
[ 54.862262] cache: parent cpu2 should not be sleeping
[ 54.862421] CPU2 is up
[ 54.862441] smpboot: Booting Node 0 Processor 3 APIC 0x6
[ 54.865272] cache: parent cpu3 should not be sleeping
[ 54.865442] CPU3 is up
[ 54.865462] smpboot: Booting Node 0 Processor 4 APIC 0x1
[ 54.868297] cache: parent cpu4 should not be sleeping
[ 54.868441] CPU4 is up
[ 54.868461] smpboot: Booting Node 0 Processor 5 APIC 0x3
[ 54.871106] cache: parent cpu5 should not be sleeping
[ 54.871256] CPU5 is up
[ 54.871274] smpboot: Booting Node 0 Processor 6 APIC 0x5
[ 54.873915] cache: parent cpu6 should not be sleeping
[ 54.874075] CPU6 is up
[ 54.874091] smpboot: Booting Node 0 Processor 7 APIC 0x7
[ 54.876729] cache: parent cpu7 should not be sleeping
[ 54.877016] CPU7 is up
[ 54.883087] ACPI: Waking up from system sleep state S3
[ 54.883654] r8168 0000:02:00.0: Refused to change power state, currently in D3
[ 54.904477] sd 0:0:0:0: [sda] Starting disk
[ 54.904478] sd 1:0:0:0: [sdb] Starting disk
[ 55.205571] OOM killer enabled.
[ 55.205572] Restarting tasks … done.


#9

DMESG Logs


#10

I am a little confused here if I am supposed to answer in english or german.
To be understood easier I will go with the latter.

Ich hatte das selbe Problem, allerdings kann ich nicht wirklich sagen ob die Ursache bei uns ebenso identisch ist. Du kannst aber einfach mal folgendes probieren:

$ cat /sys/bus/usb/devices/*/power/wakeup

Das zeigt dir an ob USB Geräte deinen Computer vom Ruhezustand aufwecken duerfen.

$ ls /sys/bus/usb/devices/

Diese Ausgabe kannst du dann durchgehen und schauen, welche Geräte enabled sind. Bei mir waren es 1-8 und 1-4. Anschließend deaktiviere diese Geräte z.B. mit

$ sudo echo disabled > /sys/bus/usb/devices/1-8/power/wakeup

Sollte dein Ruhezustand daraufhin funktionieren hast du die Ursache gefunden.


#11

Vielleicht ein kleiner Tipp. Mit

grep enabled /sys/bus/usb/devices/*/power/wakeup

spart man sich das suchen. So sieht man sofort den Pfad.


#12

Danke für eure Antworten.
Da steht bei mir:
[
flo@flo-pc ~]$ grep enabled /sys/bus/usb/devices/*/power/wakeup
/sys/bus/usb/devices/3-3.2/power/wakeup:enabled
/sys/bus/usb/devices/3-3.4/power/wakeup:enabled

Ich bin jetzt nicht so bewandert was ich jetzt tun kann deswegen wäre es toll wenn Ihr mir noch kurz das weiter vorgehen schildern könntet. Soweit glaube ich das isses der Fehler.


#13

OK habe alle USB Disabled und daran lag es nicht.


#14

Ich habe mit meinem Thinkpad Yoga ein ähnliches Problem.
Versuche mal cat /proc/acpi/wakeup. Bei mir erscheint dort:

Device  S-state   Status   Sysfs node
P0P1      S4    *disabled
XHC       S3    *enabled   pci:0000:00:14.0
HDEF      S4    *disabled  pci:0000:00:1b.0
RP01      S4    *disabled  pci:0000:00:1c.0
PXSX      S4    *disabled
RP03      S4    *disabled  pci:0000:00:1c.2
PXSX      S5    *disabled  pci:0000:04:00.0
PXSX      S4    *disabled  pci:0000:05:00.0
                *disabled  platform:rtsx_pci_sdmmc.0
                *disabled  platform:rtsx_pci_ms.0
PEG0      S4    *disabled
PEGP      S4    *disabled
PEG1      S4    *disabled
PEG2      S4    *disabled
LID0      S4    *enabled   platform:PNP0C0D:00

XHC ist wohl der Accelerometer (der kümmert sich um Bildschirmdrehungen).
Mit dem Befehl sudo sh -c "echo XHC > /proc/acpi/wakeup" kann man den mal ausschalten. Bei mir funktioniert dann der suspend mode.
Ich weiß nur noch nicht, wie ich das dauerhaft hinbekomme, denn nach einem Neustart ist der Befehl natürlich nicht mehr gültig.


#15

Bist du dir sicher? Weil eigentlich steht das XHC für “eXtensible Host Controller” und das ist eigentlich USB3.

Bei meiner Workstation habe ich nämlich auch ein XHC und das ist definitiv der USB3 Controller.

Hast du mal die PCI Adresse pci:0000:00:14.0 oder 00:14.0 mit der Ausgabe von lspci verglichen?

Für dein konkretes Problem, erstelle ein Systemd Service und starte ihn bei jedem start.

erstelle eine Datei in /etc/systemd/system/ , zum Beispiel xhc_wakeup_disabled.service , mit folgendem Inhalt:

[Unit]
Description=Disable xhc wakeup

[Service]
Type=oneshot
ExecStart=/bin/bash -c "echo XHC >> /proc/acpi/wakeup"

[Install]
WantedBy=multi-user.target

Danach systemctl enable xhc_wakeup_disabled.service

Quelle https://classicforum.manjaro.org/index.php?topic=29630.0


#16

Vielen Dank, das scheint zu helfen.
Das mit dem Accelerometer habe ich auf ner anderen Seite gelesen. Ich glaube in einem Ubuntu-Forum, wo jemand ein ähnliches Problem hatte. Hauptsache es funktioniert…
Ansonsten hast du recht:
0:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)

Vielen Dank @xabbu (Woher kommt der Name?)


#17

Von Tad Williams Otherland Tetralogie. !Xabbu ist einer der Hauptcharaktere. https://de.wikipedia.org/wiki/Otherland#Hauptcharaktere

Wobei ich hauptsächlich den Namen gut fand und ich sonst keine Ähnlichkeit mit dem Charakter habe.


#18

Hab ich gelesen! Tad Williams ist einer meiner Lieblingsautoren. Bin auch ganz gespannt auf die Fortsetzung der Großen Schwerter! Ich hatte eine Vermutung wegen des Namens, daher auch meine Frage.


#19

Sollte ich mal im Bioas XHCI deaktivieren?


#20

Edit: Wars nicht…Ich rupf mir bald die haare raus. Ich brauch mein Bereitschaftszustand wieder und auf kernel 4.9 mag ich nicht runter. Aber ich bin zuversichtlich. Ist ja Linux:-)