Rtl8821ce wireless adapter not working

Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.14.2
Distro: Manjaro Linux
Type: Desktop System: LENOVO product: 90LX0091IN v: ideacentre 510S-07ICK
serial: <superuser/root required>
Mobo: LENOVO model: 3178 v: NOK serial: <superuser/root required>
UEFI: LENOVO v: M30KT19A date: 01/31/2020
Info: Quad Core model: Intel Core i3-9100 bits: 64 type: MCP
L2 cache: 6144 KiB
Speed: 900 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 858 2: 815
3: 826 4: 855
Device-1: Intel 8th Gen Core Processor Gaussian Mixture Model driver: i915
v: kernel
Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.1
Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.4.74-1-MANJARO
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp2s0 state: down mac: a4:ae:12:2e:80:d5
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
driver: rtl8821ce
IF: wlp3s0 state: down mac: ae:8b:39:df:81:0a
IF-ID-1: enp0s20f0u10 state: unknown speed: N/A duplex: N/A
mac: aa:62:b1:72:ba:11
Local Storage: total: 1.17 TiB used: 10.77 GiB (0.9%)
ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB
ID-2: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0
size: 931.51 GiB
ID-3: /dev/sdb type: USB vendor: SanDisk model: Ultra Fit size: 28.65 GiB
ID-1: / size: 219.86 GiB used: 10.77 GiB (4.9%) fs: ext4
dev: /dev/nvme0n1p3
ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%)
dev: /dev/nvme0n1p2
System Temperatures: cpu: 39.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 192 Uptime: 13m Memory: 7.67 GiB used: 1.34 GiB (17.5%)
Shell: Bash inxi: 3.1.08

I tried kernel 5.9 and wifi stopped working . now It is not working in kernel 5.4 also. I tried reinstall linux54-headers and rtl8821ce but unable to restore wifi.

Try with rtl8821ce-dkms, this way any time the system will update kernel it’ll also update the modules

I have been in your situation until 2 days ago. Here are some relevant threads:

WIFI not working in linux 5.9.1 · Issue #176 · tomaspinho/rtl8821ce

TL;DR nobody seems to know why it is happening. Wi-Fi seems to come back shortly after a kernel update.

Why this weird thing is happening with 8821wifi adopter? Does linux latest kernels have no support for this wifi adopter??

Actually there was no support in the kernel for this adapter until 5.9, hence the need to install the rtl8821ce module separately. In 5.9 the module rtw88_8821ce is integrated in the kernel. However rtw88_8821ce does not seem to support all the versions of the hardware yet.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.