RTL8192EU Driver for TP-LINK TL-WN823N

I am installing Manjaro on my laptop, but my wifi adapter does not seem to work. I know there are Linux drivers for this device but not for Arch based distros.
Link to pdf guide> https://static.tp-link.com/2018/201812/20181207/Installation%20Guide%20for%20Linux.pdf

Hello, I just installed de RTL 8192ER Driver but I still cannot connect to my wifi network. Maybe I still need to uninstall the old wifi drivers, but I do not know how to do that.

Yes, you likely need to uninstall any Realtek Wifi drivers you installed before. As I have no way of knowing how you installed your drivers, I can not possibly advise.

You should check the source you downloaded the drivers from for uninstall directions.

Did you install the correct kernel headers as well as creating the blacklist file?

As kernel 5.4 has seen many issues with networking, it might be a good idea to install kernel 4.19 along with the linux419-headers and then reinstall the driver from the AUR.

Please post:

inxi -Fxxxz

Output for inxi -Fxxxz

System:    Host: jeremy-pc Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.4 
           tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP 1000 Notebook PC v: 088B120000305910000610100 serial: <filter> 
           Chassis: type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 1854 v: 64.22 serial: <filter> UEFI: Insyde v: F.26 date: 02/21/2013 
Battery:   ID-1: BAT0 charge: 25.9 Wh condition: 39.6/39.6 Wh (100%) volts: 12.4/11.1 model: Hewlett-Packard Primary 
           type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Dual Core model: Intel Pentium B960 bits: 64 type: MCP arch: Sandy Bridge rev: 7 L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 8783 
           Speed: 798 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Hewlett-Packard driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:0106 
           Display: x11 server: X.Org 1.20.6 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.3.1 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:   Device-1: Ralink RT5390R 802.11bgn PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 
           port: 4040 bus ID: 01:00.0 chip ID: 1814:539b 
           IF: wlo1 state: down mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 
           bus ID: 08:00.0 chip ID: 10ec:8136 
           IF: eno1 state: down mac: <filter> 
           Device-3: TP-Link TL WN823N RTL8192EU type: USB driver: rtl8192eu bus ID: 2-1.2:3 chip ID: 2357:0109 
           serial: <filter> 
           IF: wlp0s29u1u2 state: down mac: <filter> 
           IF-ID-1: enp0s29u1u1 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 698.64 GiB used: 7.76 GiB (1.1%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541075A9E680 size: 698.64 GiB speed: 3.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: A590 scheme: GPT 
Partition: ID-1: / size: 102.18 GiB used: 7.67 GiB (7.5%) fs: ext4 dev: /dev/sda8 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 148 Uptime: 28m Memory: 5.70 GiB used: 1.09 GiB (19.1%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.37 

All 3 of your network adapters are reported as being down. Do you not have a working internet connection?

I am connected via usb tethering right now. I created the blacklist like the tutorial instructed.

[jeremy@jeremy-pc realtek]$ cat /etc/modprobe.d/blacklist.conf
blacklist rtl8xxxu
blacklist rtl8xxxu

You do not need the same kernel module blacklisted twice. You can remove one of the entries.

Yeah, I ran the command twice by accident

I also just ran the command for installing the kernels headers, any ideas?

You should really install the headers before the driver install. Did you have errors thrown during the AUR driver install? If so, please post the install log.

I had installed the headers much before that, here's the log

[jeremy@jeremy-pc ~]$ sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')
[sudo] password for jeremy: 
warning: linux54-headers-5.4.6-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) linux54-headers-5.4.6-2

Total Installed Size:  47,18 MiB
Net Upgrade Size:       0,00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                                       [############################################################] 100%
(1/1) checking package integrity                                                                     [############################################################] 100%
(1/1) loading package files                                                                          [############################################################] 100%
(1/1) checking for file conflicts                                                                    [############################################################] 100%
(1/1) checking available disk space                                                                  [############################################################] 100%
:: Running pre-transaction hooks...
(1/2) Remove DKMS modules
(2/2) Save Linux kernel modules
:: Processing package changes...
(1/1) reinstalling linux54-headers                                                                   [############################################################] 100%
:: Running post-transaction hooks...
(1/4) Arming ConditionNeedsUpdate...
(2/4) Updating module dependencies...
(3/4) Install DKMS modules
==> dkms install 8192eu/83.b06d8b8 -k 5.4.6-2-MANJARO
(4/4) Restore Linux kernel modules

==> Warning:
         -> Kernel has been updated. Modules of the current kernel
         -> have been backed up so you can continue to use your
         -> computer. However, the new kernel will only work 
         -> at next boot.


I would try installing the drivers on kernel 4.19 as I mentioned earlier.

How is that done

Install kernel 4.19:

sudo mhwd-kernel -i linux419

Reeboot into kernel 4.19. Select kernel 4.19 from the grub advanced menu. When you reboot if you do not see the grub boot screen press and hold down the ESC, SHIFT or F8 key.

Install the linux headers package for your kernel.

The following command will install the linux-headers automatically for all installed kernels:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

*credit @dalto for the command

Install the driver dependencies:

sudo pacman -S dkms git

A blacklist file must be also generated to block the loading of the kernel modules at startup.

The following command will automatically generate "/etc/modprobe.d/blacklist.conf" with the correct blacklist entry:

sudo echo -e "blacklist rtl8xxxu" | sudo tee -a /etc/modprobe.d/blacklist.conf

Uninstall any wifi drivers that were previously installed.

Then restart.

If you do not already have AUR support enabled on your system then install pamac-cli.

sudo pacman -S pamac-cli

Install 1 or the other of these 2 AUR drivers:

pamac build 8192eu-dkms

or

pamac build rtl8192eu-git

After either the 8192eu-dkms or the rtl8192eu-git driver is installed issue these commands:

sudo depmod -a

sudo mkinitcpio -P

Reboot.

If you can't get the "rtl8192eu-git" driver to install (or work correctly) uninstall it, and try installing the alternate drivers from the AUR:

8192eu-dkms

or

rtl8192eu

I dont know how to uninstall the old wifi drivers tho :c

Neither do I because I have absolutely no idea which driver you installed or which method you used to install it. If you installed the driver from source on github you should search the download page for uninstall instructions.

When you've made a real mess of installing various out of kernel drivers from source sometimes it is just far cleaner to reinstall if you don't know how to undo what you've done.

This is one of the best reasons for installing timeshift so that you can roll your system back if you make a mess.

Hello, I managed to remove the wifi drivers, but at the command sudo mkinitcpio -P I get the following output:

==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> Starting build: 4.19.91-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> Starting build: 4.19.91-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> Starting build: 5.4.6-2-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
==> ERROR: module not found: `usbhid'
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> WARNING: No modules were added to the image. This is probably not what you want.
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64.img
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> Starting build: 5.4.6-2-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
==> ERROR: module not found: `usbhid'
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> WARNING: No modules were added to the image. This is probably not what you want.
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.

There is a error with: module not found: usbhid'`

PS: When using the command udo depmod --all am I not supposed to pass in the module's name?

Not required.

Please post:

lsmod | grep usbhid 

After a fresh install and a backup in Timeshift before tinkering with anything. I was able to complete your guide! Thank you so much, I learned quite a bit hahaha finally I can use Linux at college not just at home :smiley:
PS: With inxi -Fxxxz I was able yo find the drivers to be removed and using this guide I found out how to remove it.

1 Like

Forum kindly sponsored by