Rstudio: This site can’t be reached 127.0.0.1 refused to connect.

Hey folks,

i am entirely new to manjaro and like it so far. i have some experiences based on debian distributions. usually i am quite fond of helping my self, reading articles and forums to get my problems solved.
BUT this time, nothing helped, i looked for like 4 days and decided to get some help now :slight_smile:

I got this error message starting RStudio:

This site can’t be reached
127.0.0.1 refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

Hardware:
[XPS 13 (9350) mit i7-6500U, 8 GB RAM, 256 GB SSD, QHD+]

installed R Version:
installed with pacman

Name : r
Version : 3.5.1-2
Description : Language and environment for statistical computing and graphics
Architecture : x86_64
URL : https://www.r-project.org/
Licenses : GPL
Groups : None
Provides : None
Depends On : blas lapack bzip2 libpng libjpeg libtiff ncurses pcre readline zlib

  •              perl  gcc-libs  libxt  libxmu  pango  xz  zip  unzip  curl  icu*
    

Optional Deps : tk: tcl/tk interface

  •              texlive-bin: latex sty files*
    
  •              gcc-fortran: needed to compile some CRAN packages*
    
  •              openblas: faster linear algebra*
    

Required By : rstudio-desktop-bin
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 58,74 MiB
Packager : Evangelos Foutras evangelos@foutrelis.com
Build Date : Mo 06 Aug 2018 22:50:32 CEST
Install Date : Do 16 Jan 2020 22:11:57 CET
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

installed Rstudio Version:
installed with git clone

Name : rstudio-desktop-bin
Version : 1.2.5001-1
Description : An integrated development environment (IDE) for R (binary from RStudio official

  •              repository)*
    

Architecture : x86_64
URL : no links allow
Licenses : GPL
Groups : None
Provides : rstudio-desktop=1.2.5001
Depends On : r hicolor-icon-theme shared-mime-info orc openssl-1.0
Optional Deps : pandoc: markdown support [installed]

  •              pandoc-citeproc: markdown support*
    

Required By : None
Optional For : None
Conflicts With : rstudio-desktop rstudio-desktop-git rstudio-desktop-preview-bin
Replaces : None
Installed Size : 465,69 MiB
Packager : Unknown Packager
Build Date : Do 16 Jan 2020 22:04:40 CET
Install Date : Fr 17 Jan 2020 18:22:07 CET
Install Reason : Explicitly installed
Install Script : Yes
Validated By : None

other problems that might sit at the root of this:
When i try to use yay i always get this error:

yay: error while loading shared libraries: libalpm.so.11: cannot open shared object file: No such file or directory

furthermore i was not able to install rstudio with pacman, while other users reported, that it worked for them that way.

Thanks in advance and kind regards

Let's start with this problem. It looks like you installed packages without updating your system first. It is on a rolling distribution very important that you update your system before you install new packages. Always, no exceptions.

Try to update your system.

sudo pacman -Syu

reboot and check yay again.

For some reason RStudio tries to connect to a port on your local system. 127.0.0.1 is the localhost IP. Do you use any DNS Adblocker or something like this? Can you use RStudio? At which point do you see this error exactly.

Maybe it was pamac? Sometimes there is a little bit confusion about pacman and pamac. You can install rstudio-desktop-bin and any other AUR package with pamac. If you want to use pacman you have to build the package with makepkg before you can use pacman.

2 Likes

Hey xabbu,

thank you for your reply!

That is good to know, i did this after i installed manjaro initially. Did it again now, and it seems to work. I wasn't aware that i should do this every time before installing a package, so thanks a lot for that input!

Regarding Rstudio:
this happens directly when i start the application, actually it is the only thing i can see, the top toolbar doesnt work either. i am going to uninstall the package and try it via pamac.

Thanks for your help and kind regards,

stryz

EDIT: After updating everything works now, xabbu, i owe you thank you so much!

Hello,

Manjaro is a rolling release, between the date of the release disc and the date you installed it, there might be an update to do.

https://forum.manjaro.org/c/announcements/stable-updates

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by