Rstudio on Pinebook Pro (aarch64)?

I tried installing two Rstudio packages (rstudio-desktop 1.3 1093-2, rstudio-desktop-bin 1.4 1103-1) from pamac. Both return “ERROR: [package name] is not available for the ‘aarch64’ architecture.”

This site lists rstudio packages for several Fedora and Opensuse distros on aarch64, but not for Manjaro.

These instructions for installing Rstudio on Manjaro return “error: target not found: yaourt”.

Has anyone successfully installed Rstudio on a PBP/aarch64 machine, or can anyone advise me on how to proceed?

Hello @mjc :wink:

Officially rstudio is not available for arm. But i guess you should be able to compile it yourself, since opensuse provide a package for arm64 unofficially.

You will need to edit this file: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=rstudio-desktop and compile it yourself. Maybe you just need “aarch64” ?

Hi, @megavolt. Thanks for replying. Could you give me a hint as to how I go about compiling this? I’m a relative novice at that sort of thing.

@mjc

First I would look at the INSTALL file:

and maybe someone have done it already ona another OS, like this one on Debian based Distros:

and also check this one:

https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=rstudio-desktop

Then you might have an idea how this can be done. Now get the source, prepare it, install the built dependencies and run the compile script.

@megavolt

Thanks, I’ll have a go.

As someone who uses R & RStudio on a daily basis for their job, owns an aarch64 Linux device, and has put a fair amount of time into researching this, I can tell you that the RStudio avenue is going to be a dead end for you for now. On face value, the RStudio AUR packages appear to have few dependencies, but the dependencies required are hard-coded into the installation process, (many of which are x86_64-specific binaries), and the AUR packages haven’t gotten around to replacing them with libraries that can be acquired from the repos. Several of the dependencies need to be compiled using Haskell (such as pandoc), which isn’t available in the aarch64 repos yet. The Glasgow Haskell compiler can successfully be compiled from source on aarch64, but I never got around to trying to use it to build the required dependencies.

At this point in time, your best best is to install RKWard & use that. You can configure it to more or less resemble RStudio. But if you go down the route of trying to install RStudio, you’re going to have to have a long road ahead of you.

@Feakstser

Thanks, that’s good to know. I’ll try RKWard.

Sorry. I don’t mean to sound disparaging. It’s just that at the moment it would take a lot or work to get it running. In the way of RKWard, I find the lack of documentation a tad irritating. You may find it easier if you’re more familiar with KDE software. Some initial pointers for getting a more functional setup would be:

  • Right click on “R Console” at the bottom of the screen & select “Position > Right” (gives a more functional layout for most display setups).
  • Open a new script, and with the cursor in the script, select “Settings > Configure Editor…” from the top drop-down menus (this is only selectable when a script forms the ‘active’ window).
  • In the editor settings, in “Editing > General”, check the “Enable automatic brackets” option & select <>(){}[], from the drop-down menu beneath it.
  • In the editor settings, in “Editing > Indentation”, set the “Default indentation mode:” to “R”, and in the “Indent using” section, select “Spaces”, and make the Tab width and Space indentation width to 2 characters (which will mirror the behaviour of RStudio).
  • I’ll leave you to configure the rest. The only other thing you might want to take a look at is “Settings > Configure RKWard…” from the top drop-down menus. Here. in the “Add-ons > R Packages” section, you may want to set things up the way you normally do regarding repos and user package installation directories, although you may have this configured in your .Renvironment .Rprofile files. I’ve always set both as I’ve never bothered to check whether RKWard tries to override their contents with its own settings.
  • Finally, there’s no RMarkdown support in RKWard, so if you want to use this you’re going to have to write mini R scripts containing rmarkdown::render() functions in order to preview the outputs of your *.Rmd files.

Some other quality of life settings would be to add the following to your .Rprofile:

### Display ###
options(menu.graphics = FALSE) # Disable tk menus.
options(help_type = "html") # HTML help pages.

### Auto-Completions ###
utils::rc.settings(
  ipck = TRUE, # Auto-complete names inside library() and require().
  fuzzy = TRUE # Turn on fuzzy matching.
)

I seem to recall adding theses after I started to use RKWard on my Pinebook Pro.

@Feakster

No offence taken or apology needed. As I say, I’m a relative novice at this sort of thing, and I’m not planning to study it seriously in the near future.

Thanks for the further pointers.