Rpi4 no longer booting after bootloader upgrade to 210706

Hi, after the bootloader upgrade my rpi4 cannot boot anymore from the external USB3 HD. Reports “unable to read FAT partition”. Any one experiencing something similar? Any clue on how to solve?

is just a corrupt FAT partition. Have you tried:

  1. Booting from one of the Manjaro live ISOs burnt to a USB stick
    moving your external USB HDD to another Manjaro computer.

  2. Executing:

    dosfsck -w -r -l -v -t /dev/XdYn


    • X, Y and n denominate the corrupted FAT partition
    • -w means write to disk immediately.
    • -r means to do disk check interactively
    • -l means to list the filenames processed.
    • -v means verbose mode. Generates slightly more output.
    • -t means mark unreadable clusters as bad.

If you want to be sure not to lose any data, create an image of your HD first. (in this case: I would make the image on another computer)


@Darksky This maybe a bit tricky?

1 Like

I would try what @Fabby suggested first to try to straighten out the File Allocation Table for the partition using another computer.

If that did not work then on another computer:

Save the config.txt and cmdline.txt from the boot partition if salvageable somewhere.
Wipe the boot partition on the sdcard

Restore files using the latest cached kernel, raspberrypi-bootloader and raspberrypi-bootloader-x packages stored in /var/cache/pacman/pkg/. This can be done by decompressing the packages and copying over everything in each package’s boot partition to the boot partition on the sdcard.

Then copy back the config.txt and cmdline.txt you saved to the boot partition of the sdcard.

Flush the ram to the sdcard:

sudo sync

Then safely remove the sdcard from your computer and put it in the pi and see if it boots.


Managed working around the issue. Filesystem was fine. Apparently the issue was the management of GPT partitions by the new bootloader. The setup of a hybrid GPT/MBR setup made the system boot again. See RPI4 not booting anymore from GPT USB3 HD after update to bootloader 210706 · Issue #359 · raspberrypi/rpi-eeprom · GitHub for further reference.


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.