RPI3 getting pulseaudio to work


#1

I’m trying to get pulseaudio to work with Manjaro-ARM-lxqt-rpi3-18.10 freshly installed on a raspberry pi 3. If check the /boot/config.txt looks like everything is set for HDMI to support the audio. But I need the jack plugin to support the audio.

Also it looks like pulseaudio is not running, trying to open volume control just leaves it hanging on ‘establishing connection to PulseAudio. Please wait…’ forever.

I need pulseaudio for virt-viewer, I have a couple of KVM guests that can pass audio through spice. But it needs pulseaudio for the playback.

anyone an idea? Tried searching the forum, but did not find anything, otherwise do point me to the post.

inxi -A:

Audio:     Device-1: bcm2835-hdmi driver: vc4_hdmi 
           Device-2: usb-nop-xceiv driver: snd_soc_dummy 
           Device-3: simple-bus driver: snd_soc_dummy 
           Device-4: armv7-timer driver: snd_soc_dummy 
           Sound Server: ALSA v: k4.19.1-2-MANJARO-ARM 


#2

You need to turn off the force HDMI option in the config.txt.

To get pulseaudio running, run this command:
systemctl --user start pulseaudio.service

And then to enable on login:
systemctl --user enable pulseaudio.service

PS: Pulseaudio will be working on login with the next releases.


#3

@strit That fixed the pulseaudio loading, and I removed the 'hdmi_drive=2
’ line from the /boot/config.txt. If I check with inxi -A I’m guessing it is still loading the hdmi.

Audio:     Device-1: bcm2835-hdmi driver: vc4_hdmi 
           Device-2: usb-nop-xceiv driver: snd_soc_dummy 
           Device-3: simple-bus driver: snd_soc_dummy 
           Device-4: armv7-timer driver: snd_soc_dummy 
           Sound Server: ALSA v: k4.19.1-2-MANJARO-ARM 


#4

Well, you could probably switch device using alsamixer.