[RPI2/3] Manjaro-ARM 18.05 MATE Released

mate
release
manjaroarm
raspberrypi

#1

Manjaro ARM MATE 18.05 for the Raspberry Pi 2 and 3 has just released!!!

This also includes the fix for the dmesg spam by the raspberrypi-firmware package on TTY.

It comes with quite basic MATE install with not much extra.

I hope you all enjoy it!!

I’m also open to suggestions to improve the Manjaro-ARM MATE for the next releases :smiley:

Image
MD5
Torrent


#2

Looks awesome!

Congratulations on the release! :slight_smile:


#3

Not sure why, but have downloaded “Image” which is 1.4GB zip file but errors unpacking, then tried the “Torrent” download which is 1.6GB download and error unzipping, both seem to unpack 2.1GB at the point the error happen’s, File size inside the zip for both is stated to be 4.4GB.


#4

You are right. I’m getting the same error.

@GrayJack, wanna look into it?


#5

Looking into it the uploaded files are corrupted, but my local ones aren’t, so it probably was corrupted during the upload process.
I made a new zip image and I’ll uploading it, as soon as I can I’ll update the links :smile:


#6

Awesome. I downloaded the img file via torrent last night and it was corrupted so I tried the regular download and noticed it was corrupted too. Glad to know it wasn’t just me! Really looking forward to using this on my Pi since I absolutely love Manjaro on my older laptop. Thanks for all of your hard work!


#7

So, we finally updated the images, since they have the same name, just download it again :smile:

For the people that downloaded the torrent, please download it again so you can have the new image.

Also, don’t fosget to check the md5sum of the .zip file to be sure that it wasn’t corrupted in the download process.

Sorry for the trouble :smiley:


#8

Maybe this will help for next time :grinning:


#9

We don’t use osdn though. We don’t even use rsync for it, even though, we probably should start doing that instead.

Right now, we are using a Nextcloud instance to get the files to a place, where they can be rsynced to the server. So if the file gets corrupted on the way to the nextcloud server, it will also be corrupted on the download site.

Good idea @codesardine. I’ll look into this. :slight_smile:


#10

Why not sourceforge thats what i use?


#11

We have another provider for images we use. :slight_smile:

I don’t really like sourceforge that much, but I have been tempted to put it on OSDN.


#12

I just burned image to sd card and tried it in my RPI3. On first boot I was greeted with kernel panic and messages about stopping cores, after reboot it went fine. Now I spot two problems.

My wifi is not detected, I’m guessing that’s because I have it set to channel 13, it was causing troubles in raspbian too but there was handy tool that let me set wifi locale to Poland and then it worked.

Second one - application “Users and Groups” doesn’t start. If I run it from terminal it complains about libpolkit-gtk-mate-1.so.0 missing. Probably just needs it installed but it would be good to include it in image.


#13

I never had these messages before in my testings, if you ever encounter then again can you post it here so I can search for possible causes?

What handy tool? If you give us a name, we can add it to the repository if we can :smile:

Can you check if you have the mate-polkit instaled? If not, I’ll include it in the next image release. Install it and that error is probably fixed :smiley:


#14

Hi
I just did updates and now I only get kernel panic - not syncing: attempted to kill the idle task.
Here’s picture of errors. (sorry for it but I’m not very found of rewriting all of it :stuck_out_tongue:)

EDIT:
Seems my usb hub was troublemaker! I have unpluged it and it boots now. And if I connect it in DM it works fine.

EDIT2:
I have mate-polkit installed by default, yet mate-users-admin still throws:

mate-users-admin: error while loading shared libraries: libpolkit-gtk-mate-1.so.0: cannot open shared object file: No such file or directory

#15

Could be a version issue, if the mate-users-admin requires a newer or older version than what polkit-gtk-mate supplies.
What is the output of:
ls -al /usr/lib/ | grep libpolkit


#16
[manjaro@manjaro-arm ~]$ ls -la /usr/lib/ | grep libpolkit
lrwxrwxrwx   1 root root       26 Apr 18 07:41 libpolkit-agent-1.so -> libpolkit-agent-1.so.0.0.0
lrwxrwxrwx   1 root root       26 Apr 18 07:41 libpolkit-agent-1.so.0 -> libpolkit-agent-1.so.0.0.0
-rwxr-xr-x   1 root root    34140 Apr 18 07:42 libpolkit-agent-1.so.0.0.0
lrwxrwxrwx   1 root root       28 Apr 18 07:41 libpolkit-gobject-1.so -> libpolkit-gobject-1.so.0.0.0
lrwxrwxrwx   1 root root       28 Apr 18 07:41 libpolkit-gobject-1.so.0 -> libpolkit-gobject-1.so.0.0.0
-rwxr-xr-x   1 root root    95580 Apr 18 07:42 libpolkit-gobject-1.so.0.0.0

And just to confirm

[manjaro@manjaro-arm ~]$ pacman -Ss polkit | grep installed
extra/polkit 0.114-1 [installed]
community/mate-polkit 1.20.0-1 (mate) [installed]

#17

This topic was automatically closed 89 days after the last reply. New replies are no longer allowed.