[root tip] [How To] Dual boot Manjaro and Windows

Something to do with CTRL+S in BIOS. Read these comments on Acer community:

Thanks for the speedy response! I’ll jump on it very soon. Looks promising.

This is all accomplished with your systems firmware setup.

There is a lot of different systems - it is not possible to describe in details how you should navigate any given firmware.

Windows will work - as there no evidence to the contrary - even if you disable Intel Optane.

No - it is not difficult - but some major players are creating obstacles - some may say deliberately - to keep their eco system intact.

These documents are taken from topics on the now archived forum - posted by @Wollie and @c00ter

These documents is how to install / activate RST / Optane - so reversing the settings should disable it - in theory - that is

1 Like

Thank you so much for your quick response. I now have Manjaro installed, but a master key decryption lockout problem has arisen. I’m taking that to the appropriate forum. Thanks again for your detailed help.


To my knowledge Windows Bitlocker requires Secure Boot.

Manjaro do not support secure boot OOB so when disabling Secure Boot - BitLocker stops functioning.

You can read more on Secure Boot on the Archwiki using this link

Thanks so much for this guide! Long-time windows user thinking of changing to Linux here and thanks to your guide I finally made the jump.

However, after installation I had tremendous problems booting into Manjaro automatically even with @gohlip’s guide. The Manjaro boot partition was working but not showing up in the boot options in BIOS (UEFI). What solved the problem for me was flagging the boot partition with esp using gparted. Afterwards everything worked perfecty.
So, maybe it should read:

    :information_source: Skip if using BIOS/MBR
    Select the unpartitioned space → Create
    a. Size → input 512
    b. Filesystem → select FAT32
    c. Mountpoint → select /boot/efi
    d. Flags → check bootOK
    e. Flags → check espOK

A post was split to a new topic: Dual Boot when system is BIOS/MBR

Very helpful
I’m impressed with the amount of effort and detail that has gone into this

It’s been a while since I’ve had to install

I must admit to just skimming this to find what I needed and forgetting the need to choose the uefi version of the installer. :see_no_evil:

Got there in the end though
Many thanks


Some parts has been added over time - but yes - it can be quite overwhelming.

1 Like

A post was split to a new topic: Issues with rEFInd

I followed the instructions but only windows kept booting.

The solution was to boot to manjaro with usb stick by entering the following grub commands:

grub> search.file /etc/manjaro-release  root
grub> configfile /boot/grub/grub.cfg

then i had to install gparted to change the efi partition’s flag to “boot” and “esp” (It was “legacy_bios” which weird because i checked the “boot” flag when installing).
Then I run these commands in the terminal:

sudo pacman -S grub
sudo grub-install /dev/sda
sudo update-grub

and voilà.

1 Like

I feel this guide should be a bit more informative about the bcdedit /set {bootmgr} path command that is entered in the command prompt if the computer boots into windows 10 after the manjaro installation is done.

Setting the {bootmgr} path with that command creates another duplicate boot device and the issue is that it is named similarly as the windows partition’s boot device. You end up with two similarly named boot devices and well selecting either of them will still boot you into windows which is fine for most users.

But for those who wish to have an single windows partition boot device and no duplicates make sure that after you have installed and rebooted to manjaro OS successfully, boot back to windows and open command prompt with admin privileges. then type the following:

bcdedit /set {bootmgr} path \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI

Press enter after typing the above command and this will remove the duplicate boot device. Another thing is that the path that I have given above can vary, so make sure you check on another PC running the same version of windows 10 for the path.
Type bcdedit in a command prompt with admin privileges and get the path of the boot manager on the other PC.

Now this duplicate boot device cannot be erased by any software and even removing it in the PC’s BIOS also ends up restoring the duplicate device once windows boots up. Some users end up deleting the device with one of the bcdedit commands itself which screws up windows boot manager.
That set path command is modifying windows boot manager to load GRUB and when users delete this device thinking its related to manjaro, windows loses its boot manager and the PC cannot boot into windows.

So yeah I hope this reply of mine helps out someone facing this same issue of duplicate boot devices. also once the manjaro installer asks for a reboot, uncheck the reboot now box in the installer and manually restart from manjaro’s start menu. then when the PC is going to boot, hit ESC key and boot into the newly created manjaro boot device. this should complete the installation without ever going into windows and requiring you to set the {bootmgr} path.

1 Like

As a beginner I just wanted to add that (kind of) blindly following the tutorial on a UEFI system might end you up with GRUB (and thus the freshly installed Manjaro) not being available in any way: no entry in the boot list (no GRUB) and only Windows loading up after restarting - if you reboot into the live environment, efibootmgr will not show a manjaro entry anymore (despite it showing up after the installation!). For me, the Oh No - It boots directly to Windows - What do I do? solution did not help, but the following one did.

My solution was to also create a /boot partition (something that is recommended anyway AFAIK). So, aside from the EFI partition (boot/efi) created in step 6, create another one:

a. Size → input “something that might work”, I used 512
b. File system → select EXT2
c. Mount point → select /bootOK (no flags needed)

When I installed Manjaro alongside Windows 10 this way, my PC correctly booted into the GRUB menu from where I could select the operating system to launch.

Unless you installed Manjaro on a Flash Card, you should not be using EXT2 any more as it’s not a journaling FS and power losses or hard shutdowns will definitely mess up EXT2…


1 Like

Unless you installed Manjaro on a Flash Card, you should not be using EXT2 any more as it’s not a journaling FS and power losses or hard shutdowns will definitely mess up EXT2…

Thanks for the heads up! In my understanding it probably isn’t that bad of an idea to use EXT2 for that small partition (the things you mentioned are a source of danger, though I have not had issues with it on any of my computers/laptops) and I wrote that because I’ve seen it suggested to be used for /boot in a lot of places (is it some kind of myth that /boot should be EXT2 instead of EXT4? Why do people recommend it? :smiley:).

Still, my reply should probably state choose any file system you like and that Linux and the bootloader can read (where anything includes EXT4 and the likes). And then it’s probably easier to just pick the same option you picked for / and /home :slight_smile:

If reinstall manjaro to the root install partition (/) with the format flag ON, will only see one boot device in BIOS.

D’ont forget to disable BIOS Secure Boot before reinstalling manjaro.

Then after setting the BIOS Secure Boot Setting to grubx64.efi and naming it “linux”, save BIOS setting, exit BIOS and reboot.

Then re-enter BIOS to see new entry under the Boot menu:

EFI File Boot 0: linux

Position this in the required boot order listing.

  1. USB HDD:
  2. EFI File Boot 0: linux

Will see that Secure Boot is already enabled.

Then save BIOS and reboot

Should see the Manjaro screen listing the OSs with manjaro as default.

There is a way to set the default (pre-selected) OS.

Hi! I am a newbie here. :smiley:
It seems that I have encountered the same problem: only boot to windows.

Before restarting, manjaro has been added to the boot order list, but after restarting, it cannot be found in the BIOS (UEFI). After entering the live CD again, it is in the boot option list but not in the boot order list; I tried to use efibootmgr command to add it, not work. And I cannot boot to Windows after bcdedit command.

Then I tried to manually add it in the BIOS, but I found that efi partition did not appear in the partition list for adding boot item. I think BIOS cannot recognize it, maybe need flags as @Archibo (#20) said.

In the end, I add it to the Windows boot efi partition directly:

# manjaro root: /dev/sda7
# windows boot efi: /dev/sda1
sudo mount /dev/sda7 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
cd /mnt/boot/efi/EFI/
mkdir Manjaro
sudo cp /mnt/boot/grub/x86_64-efi/core.efi /mnt/boot/efi/EFI/Manjaro/grubx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro_sda1" -l "\EFI\Manjaro\grubx64.efi"

This can work. Hope windows not overwrite it.

(by google translate :slight_smile: )

1 Like

A post was split to a new topic: Dual-booting using windows bitlocker

A post was split to a new topic: Any ideas on how to integrate the NVMe driver into the Manjaro boot manager?

The link in System-Clock in the post is broken. I recommend [root tip] [How To] Get your time/timezone right using Manjaro/Windows dual-boot as a replacement.