Romanian keyboard layout missing

I am a longtime Manjaro user. I always used the winkeys variant of the romanian keyboard layout, but now I found that it’s missing in the keyboard settings. It would be nice to have it back, thank you.
Btw, why it was removed? Who makes these decisions?
Is there a way I could reinstall it in my system?


Recently, quite a lot of people had problems like this
which leads me to recommend that you check your locale settings.
This was - not for everyone, but for many people - for some reason reset to default during a recent update of glibc.

In case you don’t know how to check and repair, if neccessary:

in a terminal (or using your preferred editor as root):
open the file
and see whether your romanian locale is uncommented (the # in front needs to go …)
it’s probably the line
ro_RO.UTF-8 UTF-8
After that, run:
sudo locale-gen

Your locale should now be back.

Thank you, but it didn’t work. Instead of the winkeys variant I have another one with the name “windows”. My solution: I use an “application shortcut” (you can set it up in the Keyboard settings) with the command “setxkbmap ro winkeys” in order to use my preferred romanian layout.

All keyboard layouts need a standard. Initially the ‘cedilla’ variant was the one i used, but was old and redundant it seems. The Romanian(Windows) variant combines that with the germanic keyboard QWERTZ, and all this decisions are made upsrteam. Actually now you can use Romanian(Standard) for most keyboards.

Yeah, I know, there isn’t a big difference between winkeys and standard, but still, when I cannot find easily a key, this drives me insane.