Rofi Not Working


I’m trying out rofi and when I run any of the designated commands I get this. I’m not sure how to fix it.


I dont know ‘rofi’, but on project page it say rofi configuration is stored in


Did you build this file on your own or do you have modify it? I would start at this point for error search. :grinning:

The configuration syntax changed and you need to adapt to the new version.

I installed it in terminal, that’s it.


Which commands did you try to run exactly ?
Also, does the file ~/.config/rofi/config.rasi exist ?
If not, create it (you can leave it empty) and try rerunning your commands

I typed sudo pacman -S rofi

and when trying the config file it tells me it doesn’t exist, so I attempt to create it (the one I know how to) and it doesn’t work.

[jesse@jesse-ms7922 ~]$ ~/.config/rofi/config.rasi

bash: /home/jesse/.config/rofi/config.rasi: No such file or directory

[jesse@jesse-ms7922 ~]$ mkdir ~/.config/rofi/config.rasi
mkdir: cannot create directory ‘/home/jesse/.config/rofi/config.rasi’: No such file or directory

it’s not the right command to create a file

Do it like that:

cd ~/.config/rofi     # assuming that ~/.config/rofi exists
touch config.rasi

touch creates an empty file.
Otherwise you can use your text editor to create it

You could also try:
rofi -no-config -show run
for example.
It should disregard any configuration file - which does not even exist when you just installed it …

Thank you, this worked, the run command pops up the run app(?) (not sure “app” is the correct term for it).

CORRECTION (a few moments later) I typed rofi -show run and it worked, however typing rofi --show run which may just not be proper still does not work.

I got the double dashes from a YouTuber by the name DistroTube who did this and it worked for him (as I recall).

His video is quite old, there has been a big update recently that required everyone to modify their config files, so maybe these commands are not valid anymore.
But in general you use only one dash (unlike for standart unix commands ), for instance :

ls | rofi -dmenu

Edit : I don’t know what you wanna use rofi for but you might be interested in this page (especially the first entry)

If you are looking for rofi themes and different looks, I would look at: GitHub - adi1090x/rofi: A large collection of Rofi based custom Menu, Applets, Launchers & Powermenus.

… the double dashes simply are not a valid way to use the program - it is simply just syntactically incorrect …

You are better served using the manual page of the program

man rofi

or call the program with the -help parameter

rofi -help

or, to easily scroll through the output:

rofi -help | less

using a wrong syntax also has the same effect of showing you that usage information
many if not most programs will do that

Well, as DT presented in his video I’m experimenting on my main machine removing the stardardized “start menu” paradigm for the rofi run command instead (works for me because when I open up the start menu, whether I’m using Linux/Windows, I almost never search through the menu, I just type what I want).

Rofi has themes in its run command, I chose from there but I’ll probably take a look at the link, thanks.