Rock pi 4B doesn't boot from eMMC

I have a rock pi 4b v1.3 (It’s kinda old) with no SPI chip installed. I’m able to get Manjaro to boot from an sd card but I get an error when trying to boot from eMMC, no matter what version I try (20.10, latest from manjaro-arm-installer, buildarmimg, etc). I’ve tested booting raxda’s official ubuntu image from eMMC and it works as expected. So I don’t think there’s anything wrong with my hardware.

The error message I get:

Starting version 248.3-2-arch
:: running early hook [plymouth]
:: running hook [udev]
:: Triggering uevents...
:: running hook [plymouth]
:: performing fsck on '/dev/mmcblk2p2'
ROOT_MNJRO clean, 52696/112224 files, 418322/448727 blocks
:: mounting '/dev/mmcblk2p2' on real root
:: running late hook [plymouth]
:: Running cleanup hook [udev]
[3.197829] EXT4-fs error (device mmcblk2p2): __ext4_get_inode_loc_noinmem:4446: inode #1230: block215: comm init: unable to read itable block
ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck.

Maybe there’s something particular about my board?
Has anyone else encountered this?
Any insight would be greatly appreciated.

Your root partition acts like it is corrupted are you sure you cleanly unmounted the drive after burning the image.

Yes, definitely

[ray@pi4 ~]$ sudo rpi-eeprom-update …

Isn’t this command raspberry pi specific?
I’m not seeing it on radxa’s official ubuntu image.

I think you must have overlooked the post header.
I’m running a Rock Pi 4B, not a raspberry pi.

Oh my you are right I do not have my glasses on! Forget about my ramblings. All I saw was pi 4.
Sorry about that…

No worries.

How does your extlinux.conf file look for your eMMC install?

Also post the output of lsblk -o NAME,LABEL with your eMMC plugged into your computer.

I’ve tried various alterations to extlinux.conf (using LABEL, UUID, PARTUUID, etc),
but currently it looks like this.

FDT /dtbs/rockchip/rk3399-rock-pi-4b.dtb
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS2,1500000 root=LABEL=ROOT_MNJRO rw rootwait

and the output of lsblk…

├─sdc1      BOOT_MNJRO
└─sdc2      ROOT_MNJRO

I just tried the new 21.06 release to no avail. At this point I’m just assuming there’s something wrong with my board. Though I still find it very strange that the board operates as expected with radxas ubuntu.