Right or both sound channels are broken after 5.17 kernel update

When trying to enable any video, systems lags for unusual time, and after that can happen one of three things:

  1. Only left audio channel works
  2. No audio at all, video VERY laggy
  3. Both channels works

Restarting video multiple times usually takes to 3 route, but that’s pretty damn painful. Same thing occurs with sound in video games, etc.
Also, while one video on background with both channels working is running, usually every other video plays without an issue.

And if you boot into 5.15 kernel do you have the same experience ?

Can’t say for sure, since that happens very unpredicatble, but it seems like everything works as expected on 5.16.

Updated pipewire to 0.3.49, but nothing changed in a good side – sound bug still exists. Also, now mpv refuses to close. It’s only possible to close it with killing the process

Ah, mpv bug seems not related to this: ao_pipewire: mpv hangs on quit when playing any audio · Issue #10033 · mpv-player/mpv · GitHub
Updated kernel to 5.17.1-3, will write if problem still persists.

UPD. Nah, nothing changed

Which info can be helpful in this regards? Since this is a very occasional bug, I don’t know what and with which commands I can provide

After 3 days of usage of 5.16 kernel it happened again. Also there’s a new bug: sometimes audio just starts looping for 1-2 second frame and the whole system freezes completely. I can’t even get to tty.
Tried replacing manjaro-pipewire with manjaro-pulse but that didn’t help. System’s completely unusable in current state

inxi -Fxxxz:

  Kernel: 5.17.1-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Nitro AN515-45 v: V1.08
    serial: <superuser required>
  Mobo: CZ model: Scala_CAS v: V1.08 serial: <superuser required>
    UEFI: Insyde v: 1.08 date: 07/21/2021
  ID-1: BAT1 charge: 54.5 Wh (99.8%) condition: 54.6/57.5 Wh (95.0%)
    volts: 17.1 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
    status: N/A
  Info: 6-core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64
    type: MT MCP smt: enabled arch: Zen 3 rev: 0 cache: L1: 384 KiB L2: 3 MiB
    L3: 16 MiB
  Speed (MHz): avg: 2948 high: 3318 min/max: 400/4280 boost: enabled cores:
    1: 3134 2: 2907 3: 3292 4: 2886 5: 2684 6: 3088 7: 2649 8: 2786 9: 2614
    10: 3094 11: 2935 12: 3318 bogomips: 79080
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
    vendor: Acer Incorporated ALI driver: nvidia v: 510.60.02 pcie:
    speed: 2.5 GT/s lanes: 8 bus-ID: 01:00.0 chip-ID: 10de:2520
    class-ID: 0300
  Device-2: AMD Cezanne vendor: Acer Incorporated ALI driver: amdgpu
    v: kernel pcie: speed: 8 GT/s lanes: 16 ports: active: eDP-1 empty: none
    bus-ID: 06:00.0 chip-ID: 1002:1638 class-ID: 0300
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:2
    chip-ID: 0408:a061 class-ID: 0e02
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: amdgpu,nvidia unloaded: modesetting,nouveau
    alternate: fbdev,nv,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x1521 res: 1920x1080
    hz: 144 dpi: 142 size: 344x193mm (13.54x7.6") diag: 394mm (15.5") modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.1-3-MANJARO)
    v: 4.6 Mesa 22.0.1 direct render: Yes
  Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s
    lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: N/A pcie: speed: 8 GT/s lanes: 16
    bus-ID: 06:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.1-3-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 04:00.0
    chip-ID: 10ec:2600 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: Lite-On driver: mt7921e v: kernel pcie: speed: 5 GT/s lanes: 1
    bus-ID: 05:00.0 chip-ID: 14c3:7961 class-ID: 0280
  IF: wlp5s0 state: up mac: <filter>
  Device-1: Lite-On Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 04ca:3802 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
  Local Storage: total: 1.38 TiB used: 509.7 GiB (36.2%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: OM8PDP3512B-AA1
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: EDFK0S03 temp: 42.9 C scheme: GPT
  ID-2: /dev/nvme1n1 vendor: Western Digital model: WDS100T1X0E-00AFY0
    size: 931.51 GiB speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 614600WD temp: 62.9 C scheme: GPT
  ID-1: / size: 922.42 GiB used: 206.48 GiB (22.4%) fs: btrfs
    dev: /dev/nvme1n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 572 KiB (0.2%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-3: /home size: 922.42 GiB used: 206.48 GiB (22.4%) fs: btrfs
    dev: /dev/nvme1n1p2
  ID-4: /var/log size: 922.42 GiB used: 206.48 GiB (22.4%) fs: btrfs
    dev: /dev/nvme1n1p2
  ID-1: swap-1 type: partition size: 8.8 GiB used: 2.45 GiB (27.9%)
    priority: -2 dev: /dev/nvme1n1p3
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
  Fan Speeds (RPM): N/A
  Processes: 350 Uptime: 33m wakeups: 1 Memory: 15.05 GiB
  used: 5.08 GiB (33.7%) Init: systemd v: 250 Compilers: gcc: 11.2.0
  clang: 13.0.1 Packages: pacman: 1825 Shell: Zsh v: 5.8.1 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.14

Apparently not as still system is using both …

Yes, I’ve reinstalled it back since it took no effect

One workaround I’ve found is to run any video or software with correct sound in background loop. While it’s working – every other video/software works the same way

Tried monitoring the KSystemlog for updates, when hearing that nasty cracking sound, but it seems like it doesn’t appear in this log. What else can I do?

Finally I’ve found out what the problem was with help of this video.

What I did, is installed tlpui and set SOUND_POWER switches to 0 0 N

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.