Right click on browser shortcut doesn't bring application specific options

I liked how when you clicked a shortcut (in this case to Brave Browser) that was pinned to the bottom panel in Linux Mint Cinnamon, it gave the option of opening an incognito window.

This was especially nice since I have my browser set to restore the previous session where I often have grouped tabs for different ongoing projects and I use that function to quickly access a clean private window without needing to open the browser first. Now, in Manjaro GNOME this is not the case.

This is an incredibly small thing but if there is some way to gain this functionality or some other way to perform this action of launching a new private window specifically that would be great. Looking this up has yielding no relevant results so I thought I’d try my hand here. Thanks to anyone who responds.

This function is provided by an extension called Dash-to-dock. You can enable it under Layouts > settings > Gnome extensions.
Hope this is what you’re looking for :slightly_smiling_face:

EDIT: If you’re using a touchpad: Gnome defaults to two-finger-tap for “right-clicks”.

Actually that’s default, no extension required. The shortcuts like New Window on a browser icon are declared in the desktop file as a Desktop Action. Example:

[Desktop Entry]
Name=Foo Viewer
Comment=The best viewer for Foo objects available!
Exec=fooview %F

[Desktop Action Gallery]
Exec=fooview --gallery
Name=Browse Gallery

[Desktop Action Create]
Exec=fooview --create-new
Name=Create a new Foo!

So, if I’m understanding correctly, I can edit this file to add another action? Do you know where these are kept? Thanks for the reply, really loving the Manjaro project.

If you want to edit a desktop file, copy it from where it’s installed in the system to your user folder. Otherwise it will be overwritten the next time there’s a package update. Example:

cp /usr/share/applications/fooview.desktop ~/.local/share/applications/

I did what you said, but when I went to edit the desktop file I found that there was already an action listed to open an incognito tab. Not sure why it isn’t showing up when I right click a shortcut.

However, I did discover the command to open an incognito tab when I was looking at the desktop file, something I was not privy to as I am not a heavy terminal user. I might just create a keyboard shortcut to perform this function, unless you have any idea why the option isn’t showing up in the right click menu.

Regardless, thanks for your help in this matter.

Edit: Thought it might be worthwhile adding what I am referring to in the desktop file

[Desktop Action new-private-window]
Name=New Incognito Window
Exec=brave --incognito

I don’t unless an extension is interfering. Do you use Dash to Dock, Dash to Panel or any other extension that modifies the panel or application grid?

Does the issue occur with both the dash and application grid?

I don’t use dash to dock or panel and I don’t have any extensions which modify the appications menu. I primarily use the ArcMenu extension to access everything I need from the top bar. The issue is present in the ArcMenu, dash, and application grid.

Try disabling Arc Menu and see if you can reproduce the issue.

To be sure and extension is completely unloaded, restart GNOME Shell or logout after disabling.

Done. The issue continued to persist after disabling ArcMenu and logging out.

What extensions do you have enabled?

gnome-extensions list --enabled

Okay, here is the output.


The forums wouldn’t let me post more than 5 links so I deleted the dot com from the last two

Hmm, nothing should be affecting anything. What if you create a new user with no extensions enabled?

EDIT: I don’t know if it will make any difference, but I just updated ArcMenu to v11 in the stable branch and v12 in the testing and unstable branches.

Okay, I’ve tried that now and it persisted with the new user after turning off extensions. I’m not sure how to update ArcMenu. I’ve tried syncing the repositories but everything still shows as v8.

Your mirrors haven’t updated yet. If they still haven’t, sync the fastest 5 mirrors and update:

sudo pacman-mirrors -f5 && sudo pacman -Syyu

Ah thanks, I’ve updated to v11 and the issue is still present.

Strange. What is in the right-click menu? You should at least have Show Details, New Window, etc.

Yeah it just shows the the basic functions.
Current Windows, New Window, Remove from Favorites, Unpin from ArcMenu, Show Details.

Not sure how long it’s been fixed but after updating my system after a 3 day vacation a couple days ago the issue has been resolved. Thanks for the help and I did get something out of it i.e. making a keyboard shortcut which I have grown quite fond of.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.