RGB and YUV not found PCSXR and PCSX2

After going through this and upgrading my system I have a new stumbling block with my emulators.

For PCSXR/PCSX2 I get the following output:

[lerner@manjaro ~]$ pcsxr
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
RGB & YUV not found.  Quitting.

and for ZSNES:

[lerner@manjaro ~]$ zsnes
ZSNES v1.51, (c) 1997-2007, ZSNES Team
Be sure to check http://www.zsnes.com/ for the latest version.

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
and you are welcome to redistribute it under certain conditions;
please read 'LICENSE.TXT' thoroughly before doing so.

Use ZSNES -? for command line definitions.

Starting Mouse detection.
Unable to poll /dev/input/event16. Make sure you have read permissions to it.
Unable to poll /dev/input/event15. Make sure you have read permissions to it.
Unable to poll /dev/input/event14. Make sure you have read permissions to it.
Unable to poll /dev/input/event13. Make sure you have read permissions to it.
Unable to poll /dev/input/event12. Make sure you have read permissions to it.
Unable to poll /dev/input/event11. Make sure you have read permissions to it.
Unable to poll /dev/input/event10. Make sure you have read permissions to it.
Unable to poll /dev/input/event9. Make sure you have read permissions to it.
Unable to poll /dev/input/event8. Make sure you have read permissions to it.
Unable to poll /dev/input/event7. Make sure you have read permissions to it.
Unable to poll /dev/input/event6. Make sure you have read permissions to it.
Unable to poll /dev/input/event5. Make sure you have read permissions to it.
Unable to poll /dev/input/event4. Make sure you have read permissions to it.
Unable to poll /dev/input/event3. Make sure you have read permissions to it.
Unable to poll /dev/input/event2. Make sure you have read permissions to it.
Unable to poll /dev/input/event1. Make sure you have read permissions to it.
Unable to poll /dev/input/event0. Make sure you have read permissions to it.
ManyMouse: 0 mice detected.
Segmentation fault (core dumped)

Current setup is an FX6300 black 6 core, DDR3 1866 8GB RAM, and a 4GB OC RX460 video card, GNOME 3 desktop, and linux-amd-staging kernel. I did, however, have this issue before changing to the amd kernel and before having sound as well. Any help is appreciated!

I forgot to mention I went from Intel to AMD and NVIDIA to an RX460. Think that has something to do with it?

I hate to keep bumping my own thread, but I have found solutions to everything except ZSNES and M64py. Stella, FCEUX, Dolphin, GnesGS, PCSXR, and PCSX2 all load now.

For PCSXR I changed the graphics driver under Plugins & BIOS to OpenGL Driver 1.1.78, same with PCSX2. Still trying to figure out ZSNES, though, and instead of replying to my own thread again I will edit this post.

Edit: I got ZSNES to work by removing the .zsnes folder from home after making a backup and opening ZSNES and replacing my save files, but now it won’t go full screen. Still can’t get M64py to run due to an invalid public key from the AUR

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark