[Resuelto] Instalación Joplin en Manjaro


#1

Hola,

He reinstalado Manjaro de nuevo en mi equipo y tengo problemas en la instalación de la aplicación Joplin des de un archivo tar.gz que me he descargado de la web https://aur.archlinux.org/packages/joplin/
lo he descomprimido y he usado el comando makepkg

[user@user-pc joplin]$ makepkg -fc
==> Creando el paquete: joplin 1.0.119-1 (dom 23 dic 201
8 11:09:28 CET)
==> Comprobando dependencias mientras se ejecuta...
==> Comprobando dependencias mientras se compila...
==> Recibiendo las fuentes...
 -> joplin.desktop ha sido encontrado  
 -> joplin-desktop.sh ha sido encontrado  
 -> joplin.sh ha sido encontrado  
 -> v1.0.119.zip ha sido encontrado  
==> Validando los archivos source con sha256sums...
   joplin.desktop ... Aprobado
   joplin-desktop.sh ... Aprobado
   joplin.sh ... Aprobado
   v1.0.119.zip ... Aprobado
==> Extrayendo las fuentes...
 -> Extrayendo v1.0.119.zip con bsdtar
==> Eliminando el directorio $pkgdir/...
==> Iniciando build()...
npm WARN tools@1.0.0 No description
npm WARN tools@1.0.0 No repository field.

audited 95 packages in 1.977s
found 3 vulnerabilities (1 moderate, 2 high)
 run `npm audit fix` to fix them, or `npm audit` for de
tails
audited 827 packages in 3.089s
found 8 vulnerabilities (5 low, 1 moderate, 2 high)
 run `npm audit fix` to fix them, or `npm audit` for de
tails

> Joplin@1.0.119 postinstall /home/user/Apps/joplin/src/
joplin-1.0.119/ElectronClient/app
> node compile-jsx.js && node compile-package-info.js &&
node ../../Tools/copycss.js --copy-fonts && install-app
-deps

 • please use as subcommand: electron-builder install-a
pp-deps
 • electron-builder version=20.14.7
 • loaded configuration file=package.json ("build" fiel
d)
 • rebuilding native production dependencies platform=l
inux arch=x64
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin
-win@2.1.1 (node_modules/7zip-bin-win):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupporte
d platform for 7zip-bin-win@2.1.1: wanted {"os":"win32",
"arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: 7zip-bin
-mac@1.0.1 (node_modules/7zip-bin-mac):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupporte
d platform for 7zip-bin-mac@1.0.1: wanted {"os":"darwin"
,"arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents
@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupporte
d platform for fsevents@1.2.4: wanted {"os":"darwin","ar
ch":"any"} (current: {"os":"linux","arch":"x64"})

audited 3945 packages in 12.983s
found 3 vulnerabilities (1 low, 1 high, 1 critical)
 run `npm audit fix` to fix them, or `npm audit` for de
tails

> Joplin@1.0.119 compile /home/user/Apps/joplin/src/jopl
in-1.0.119/ElectronClient/app
> node compile-jsx.js && node compile-package-info.js &&
node ../../Tools/copycss.js --copy-fonts

> Joplin@1.0.119 pack /home/user/Apps/joplin/src/joplin-
1.0.119/ElectronClient/app
> electron-builder --dir

 • electron-builder version=20.14.7
 • loaded configuration file=package.json ("build" fiel
d)
 • writing effective config file=dist/electron-builder-
effective-config.yaml
 • rebuilding native production dependencies platform=l
inux arch=x64
 • packaging       platform=linux arch=x64 electron=1.8
.7 appOutDir=dist/linux-unpacked
 • asar using is disabled — it is strongly not recommen
ded solution=enable asar and use asarUnpack to unpack fi
les that must be externally available
==> Entrando en entorno fakeroot...
==> Iniciando package()...
==> Depurando la instalación...
 -> Quitando los archivos libtool...
 -> Purgando los archivos innecesarios...
 -> Quitando los archivos de las bibliotecas estáticas.
..
 -> Despojando los símbolos innecesarios de los binario
s y de las bibliotecas...
strip: No se puede reconocer el formato del fichero de e
ntrada `./usr/share/joplin/resources/app/node_modules/7z
ip-bin-linux/arm/7za'
strip: No se puede reconocer el formato del fichero de e
ntrada `./usr/share/joplin/resources/app/node_modules/7z
ip-bin-linux/arm64/7za'

No sé si debo hacer alguna acción en especial para que reconozca el formato de ese archivo, tengo instalado el 7zip…

Gracias de antemano.


#2

He probado de nuevo el mismo comando y mientras estaba mirando unas cosas se ha resuelto solo, era cuestión de esperar. :slight_smile:

Se me ha creado el paquete pkg.tar.xz correctamente y acto seguido he realizado la instalación con el comando:

sudo pacman -U joplin-1.0.119-1-x86_64.pkg.tar.xz

Y funciona todo :+1: