"Restore the GRUB Bootloader" wiki.manjaro simple-question

Regarding this wiki.manjaro link:
https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader#For_BIOS_Systems
What does “separate” in the following sentence explicitly mean?
i.e. in context jon
IF you have used a separate partition for your GRUB bootloader, then this must also be mounted. The syntax to mount a separate partition used to boot is:…
I’ve done this about four or five times before with success, but recently it hasn’t worked with a multi-boot of W-10 and Manjaro and Mint so I assumed it was Windows and removed everything (but DATA partition) and tried to install Manjaro and Mint in dual-boot mode and received different errors after many unsuccessful attempted installs very similar to: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown…
Given: GPT, UEIF Installed Mint 19 xfce first, then attempted to install Manjaro 17.1 xfce (latest version)
Currently, I am not getting this error and it is just booting to Mint, (check bios at start up [F9 on HP]0, does not recognize/show Manjaro, sudo update-grub from Mint, post Manjaro install didn’t help, from Mint sudo su, cd /boot/efi/EFI shows Ubuntu and Manjaro somethings (don’t know linux, or terminology, or difference between a bootloader and grub2 (same?), and bios, etc.
The reason for providing this info is because I am going to attempt to try and dual-boot Mint and Manjaro, but I’m about done trying and I would like to know what is meant by a separate partition in that sentence.
Wouldn’t all installations have a separate partition, usually it would be an ESP EFI partition on /dev/sda1 with the boot and esp flags set.
Do they mean “another” partition, or another separate partition as opposed to separate?
I don’t want to try it one way, reinstall, and try it the other way or have it give me the Kernel panic errors as there are links to links to links (total of about 12) with about 6 different suggestions to solve the kernel panic issues and I suspect that the knowledgeable forum members expect too much out of some of us newbies. The distro should be a tool, I shouldn’t be the tool of the distro, which includes trying to decipher what link to use or what is meant by such link (the wiki link is very legible, but some of the forum advice is not so legible and very scattered like a conversation, not a textbook) If I can’t dual-boot both distros, I’ll just use Mint as a main one, and maybe put Manjaro on an older laptop.

Anyway, during the GPT UEFI install I left the device “Under choose device for bootloader” as /dev/sda a disk, not a partition, but I assume that the bootloader grub is on my /dev/sda1 ESP EFI partition.
Or is my error in thinking that the bootloader is installed on the ESP EFI partition, and it is indeed installed on the /dev/sda disk itself?
It partially seems as though the bootloader must be installed at a specific spot on a disk, and that would seem to be a partition. If I’m wrong, then the bootloader (assume GRUB2) would be installed on the disk itself - and not a partition.
My original question has priority and is what I would like an answer to the most so that I can try to restore the GRUB bootloader.
I will appreciate any advice and thank you for taking the time to read my concerns and I somewhat apologize for complaining about my pedantically perceived communication issues, but if I’m (newbie) not familiar with the subject, ambiguous communication just creates another puzzle to solve - to which I become the tool.

Different. Distinct. Isolated. Apart. Divided. Unconnected. Disjoined.

Before I’m banned:

I am getting a Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) error after installing mint. Attempted installation about 6 times lately and I had to install Manjaro first as that is the only way that I could get it to install. Rechecked iso.sig on several dl (instruction not explicit, had to go to peppermint forum for order, Manjaro instructions assume a lot and lacks in communication) reinstalled several times, once Manjaro worked for a while, then quit, lately I’m getting this kernel panic after installing Mint after Manjaro. I’m on the laptop with the issue now as I was able to boot into a fallback initiaram (or similar).

I see that this is too rare of a problem to placed in a manual, but which specific forum, and what advice in a specific forum do I follow; e.g.

Re: Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Do I try #15, 16, or 29 (numbered search results for hooks), and is this still relevant.

Seems like it may be in /etc/mkinitcpio.conf or grub, or both.

Or do I try the instructions from this:


This has almost as many contradictions as the bible!

Seems as though it may be in grub only.

Or do I try the instruction from this:
This is a known issue. The Grub bootloader settings of most distros cannot boot Manjaro and Arch. You need to make Manjaro take control of Grub again.

Seems to need the bootloader restored, or editing the grub per philm, which references this link:

which seems to suggest using a grub rescue cd to boot into manjaro.

Or do I try this one.

which references:
https://bbs.archlinux.org/viewtopic.php?id=199710
and
https://ubuntuforums.org/showthread.php?t=1751574
and
https://wiki.gentoo.org/wiki/Knowledge_Base:Unable_to_mount_root_fs
and
https://forums.fedoraforum.org/showthread.php?262786-Kernel-panic-not-syncing-VFS-Unable-to-mount-root-fs-on-unknown-block(0-0)

all which somewhat (TLDNR) suggest the grub, the wrong kernel, or fstab.

Manjaro definitely doesn’t need a manual,

Manjaro shouldn’t be this hard to install, I installed it many times over the past few years it usually installed fine even if I had to use CLI.
If I am doing something incorrect I WILL be the first to admit it as I want to be correct, not right, and that could very easily be the case because if I knew what I was doing incorrectly I wouldn’t be doing it.

And we definitely don’t need a manual like this:

Frankly, this:

“Ranking your mirrorlist:

Adding a number to -f/–fasttrack command will return a number of up-to-date and responsive mirrors

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

You should sync the database after running this command by using:
pacman -Syyu
Optimize the database access speed
For full benefit, run this command after syncing the database.

pacman-optimize && sync” (optimize not recognized)

is pathetic.

When will linux be the next desktop which is sophomoric, but….

Different. Distinct. Isolated. Apart. Divided. Unconnected. Disjoined.

from what? It can’t be distinct in a vacuum - in context.

Yea, don’t need a manual (for other issues), we have this helpful forum with exemplary
Community Managers!

You are probably fun to hang out with, yeah?

If I’ve deciphered these ramblings it comes down to a basic issue of you allowing a different grub than manjaro’s to take over. Manjaro’s grub can boot other distro’s. Other distro’s grub cannot boot manjaro. I feel this has been beaten to death already.

But what I really want to know is … what does any of what you wrote have to do with this? Like, what is your issue exactly? Do you have a problem with forums in general - where people with different systems post issues and get help? Are you upset that you cant seem to find one that fits you exactly? Does that mean others should never have their own threads? What is pathetic about mirror-ranking, and what does pacman have to do with your issue?

2 Likes

Please take time to go over the Forum Rules as they will be of immense help to you if you want to benefit from using this forum.

Do not cloud your issue in ramblings about this or that as this will only cause your issue to be ignored as no one here bother TL:DR posts about nothing.

You replied, must of read some of it; and ditto.

Confused troll is confused.
See the thing is, regardless of your incontestable prowess in the Language Arts and English specifically, the content is woefully lacking.
You can play nice and accept that you did something wrong or that you did not understand and follow proper advice from people who just might be better informed on the subject…
Or you can continue to be a whiny pedant that everyone is happy to ignore. Your choice smarty pants.

You obviously have ignored the forum rules.

Please do read https://wiki.manjaro.org/index.php?title=Forum_Rules#How_to_Post and comply.

And - by the way - you are not banned, yet.

But rest assured - if you continue with the attitude you have shown till now - you will.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by Bytemark