[Resolved] RTX 3050 not recognised

Hello,

I just installing a new manjaro with XFCE after buying un new laptop.
screenfetch command give me the intel GPU for result.
And this command : “lspci -v | grep ‘VGA|3050’” give me these results.

00:02.0 VGA compatible controller: Intel Corporation TigerLake-H GT1 [UHD Graphics] (rev 01) (prog-if 00 [VGA controller])
01:00.0 3D controller: NVIDIA Corporation GA107M [GeForce RTX 3050 Mobile] (rev a1)

thanks for answers.

ps:English is not my first language.

You probably need to install the hybrid driver from Manjaro Settings → Hardware

Give your system information from command inxi -Fazy and put the output of terminal in your reply between three backticks, the following way to have it properly formatted and readable:

```
the terminal output here between three backticks before and after
```

The forum will properly format it as a “code” block instead of plain text so it keeps proper readability.

Ok sorry I did’t know that.

System:
  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=1ed4b720-7d56-48ef-a85a-72112e8f00fe rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Micro-Star product: Katana GF66 11UC v: REV:1.0
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: Micro-Star model: MS-1582 v: REV:1.0 serial: <filter>
  UEFI: American Megatrends LLC. v: E1582IMS.307 date: 06/11/2021
Battery:
  ID-1: BAT1 charge: 49.4 Wh (93.7%) condition: 52.7/52.0 Wh (101.2%)
  volts: 12.7 min: 11.4 model: MSI BIF0_9 type: Li-ion serial: N/A
  status: Unknown
CPU:
  Info: 6-Core model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP
  arch: Tiger Lake family: 6 model-id: 8D (141) stepping: 1 microcode: 2C
  cache: L2: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 64536
  Speed: 801 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 801 2: 800 3: 801
  4: 800 5: 800 6: 801 7: 801 8: 800 9: 800 10: 800 11: 840 12: 800
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Micro-Star MSI
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Micro-Star MSI
  driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
  chip-ID: 10de:25a5 class-ID: 0302
  Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 3-10:3
  chip-ID: 5986:211b class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.1 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
  display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2")
  s-diag: 1055mm (41.5")
  Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 142 size: 344x193mm (13.5x7.6")
  diag: 394mm (15.5")
  Monitor-2: HDMI-1 res: 1920x1080 dpi: 82 size: 598x336mm (23.5x13.2")
  diag: 686mm (27")
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.5
  direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI
  driver: sof-audio-pci-intel-tgl
  alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
  chip-ID: 8086:43c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
  bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 3-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 476.94 GiB used: 9.93 GiB (2.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PCP3512F-AI1
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: ECFK52.8 temp: 35.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 97.66 GiB size: 95.56 GiB (97.86%) used: 9.91 GiB (10.4%)
  fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%)
  used: 27.8 MiB (9.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 288 Uptime: 10m wakeups: 1 Memory: 7.47 GiB
  used: 1.89 GiB (25.2%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1079 lib: 312 flatpak: 0 Shell: Bash v: 5.1.8
  running-in: xfce4-terminal inxi: 3.3.08

Seems like you already have your hybrid video driver installed, so your system should be working properly, you could use the Nvidia video card for gaming with the proper commands when running a game.

To verify that you actually have the proper setup and that it is working you can give the output of the following commands

list the installed drivers with mhwd -li
list the card used by default (should be Intel) glxinfo | grep renderer
list the card used by offloading (should be Nvidia) prime-run glxinfo | grep renderer

There is no problem in my opinion currently with your system. Your Nvidia card is recognized. But having an hybrid system requires you to force the usage of Nvidia card, by default it will work with the Intel card only. There are possibilities to disable the Intel card permanently, or to setup the system in a different way for the Nvidia card to be the default card and the Intel to be the offloading card too, but I’m not sure this is something you’re asking.

Ok the three commands you asked me.

e[1me[31m> e[mInstalled PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
     video-modesetting            2020.01.13                true            PCI


e[1me[31mWarning: e[mNo installed USB configs!
    GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_NV_float_buffer, 
    GLX_MESA_copy_sub_buffer, GLX_MESA_query_renderer, GLX_MESA_swap_control, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel(R) UHD Graphics (TGL GT1)
OpenGL renderer string: NVIDIA GeForce RTX 3050 Laptop GPU/PCIe/SSE2

It shows what you were waiting for ?
Now, my question would be, how to force NVIDIA card when I open a game for example.
Or if is’t not possible how to only use NVIDIA card.
I use a laptop but it’s always plugged so it doesn’t matter if it’s more energy consuming.

To me it seems it is working as intended, yes. By default with the Intel/Nvidia hybrid driver it is the Intel card that is used, and you can “offload” the work on the Nvidia card, on demand.

To offload to the Nvidia card you run your program with the prime-run command, for example start a game with prime-run name-of-game-executable.

For Steam games you need to modify the Launch Options, in the game Properties. Right click the game in the Steam Library, go to Properties, then add this in the Launch Option field prime-run %command% exactly as is, there is no typo this is what you need to write.

Thank you so much it works !