[Resolved] Nvidia MX150 HP envy laptop - cant't install Manjaro i3 version, black screen after GRUB

laptop
nvidia
i3
installation
hp

#1

Hello,

I’m using Manjaro i3 version on my home and work PC’s (both are desktops) for a year.

Recently, I get laptop HP Envy x360 15-cn0006na, which have Nvidia MX-150 GPU and Intel i7-8550U CPU.

I’m strugglin to install Manjaro i3 there.

I’m using latest ISO with i3 community version, and USB flash drive, for live installation.

GRUB is working fine, but after I try to boot in to system, I get black screen.
There is no cursor pointer, “_” or any other symbols.
Nvidia driver change from free to non-free doesn’t change anything.

Probably related with video drivers, so I did tried “nomodeset” boot.
In this case I get black screen with “_” symbol in top-left corner.
But i’m not sure I did everything right since i’m desktop user and not experinced with laptop graphics common issues.

Any help and advice is apricciated.


#2

Last time I tried i3 edition live media on my laptop (same CPU & GPU), it worked fine w/o any issues. Have you tried other editions like Gnome or KDE? Maybe something is broken in recent i3 iso…


#3

Which version worked for you?

Have you tried the most recent version? Or the same version as the OP? That would provide a useful baseline.


#4

Sorry, I don’t remember as pretty soon I realised that i3 is not for me so I rebooted back to my Plasma system and deleted i3 iso. All I can say is that “tryout” took place in the beginning of August.


#5

I found my backup USB drive with ~6 months old Manjaro i3 version - same result.

Will try to install gnome/kde versions today.


#6

I’d also suggest to post the output of inxi -Fxxxz to let us see your laptop’s specs.


#7

Resolved.

I had to use Manjaro-Architect ISO, with non-free drivers and nomodeset option.

Installed system boots and work fine.


closed #8

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.