[RESOLVED] Installation fails -- won't accept password (Manjaro Budgie)


#1

I’ve tried several times to install Manjaro Budgie from a thumb drive, but each time fails.

I have existing LVM partitions, two of which already have OSes on them. So in the install I selected the option to replace an existing partion and selected the free one. The install seems to proceed fine with no errors, then takes me to a screen just showing wallpaper. As soon as I move the mouse, it asks for a password, and it will not accept the password I provided during setup. If I select “Switch user”, it takes me to a dialog that has no option to select which user account to use. There is a button to change desktop environment, and an input field for password. That’s it. And it will not accept my password.

I tried to the install again and told it to not require password, but I get the same thing.

When I remove the thumb drive and reboot, I find myself in grub recover mode and have to recover my grub menu to be able to boot.

What’s going on?


#2

It looks like it actually did install to the partition OK after all. I just have no grub boot menu.

I ran grub-mkconfig and it saw the Manjaro partition. So I rebooted and was able to boot into the Manjaro partition OK.

So it looks like there were two problems:

  • After installation was complete, it prompted for a password and would not accept any. This was confusing, and there was no feedback as to what was going on.
  • It wiped out whatever config grub needs to present a boot menu at startup.

I don’t know much about grub, so had to figure out how to get my boot menu back. Every time I restarted, I found myself in grub recovery mode. I was able to find instructions as to what commands to give in recovery mode to get it to boot from a partition. I used the following commands:

set prefix=(hd0,msdos3)/boot/grub
insmod normal
normal

It then restarts, and I can see by grub boot menu. After booting into an OS, is used grub-install to remember this and show the boot menu after each restart.

Sorted out, now, but this was not a seamless install. Have others not had this issue? Anyway, it seems to be working and I can boot into it. (And it boots into it very quickly. That’s nice.)


closed #3

This topic was automatically closed after 90 days. New replies are no longer allowed.