Resolvconf is not working

Good afternoon, I tried to change DNS but it didn’t work, I don’t know why, I applied this Tutorial but I got this issue

do not post screenshots of text - screenshots removed
i tried it on Ubuntu i got same issue

To change your providers DNS server to some custom DNS server
(the providers is usually what your router will give you)

you access the panel icon → right click → edit connections → go to IPv4 settings tab → change the method
from "automatic (dhcp)
to: automatic (dhcp), addresses only
then put your DNS server(s) in the aptly named field below.
separate two with commas (there is a tool tip when you hover over the field)

do the same for IPv6 … or leave it like it is

Don’t use random youtube videos as a reference - there are wikis for Manjaro and Arch and on how the NetworkManager works.

Be so kind and remove your (unhelpful) screenshot. Thanks!

btw:
openresolv was already installed - you just reinstalled it
(read it in the terminal output)

1 Like

Thank you brother for the reply and help, I tried it too but it didn’t work I didn’t find the option automatic (dhcp), addresses only and here is the result.

do not use screenshots of text - provide context in writing

do not use screenshots of text - provide context in writing

Which screenshot do you mean, I think the one with the tool installation?

I’m using Xfce4 - you are using Gnome.
It looks a bit different, but the options are the same - also: I did translate it freely, my system isn’t in english

You could have just said what you are using.

… I think it is the one where the DNS that you put in is not red

what you want is to get an IP from your router, but not also the DNS server address which it also provides

Automatic, DHCP and the switch labelled “Automatic” turned to “off”

remove your screenshots please - use words :sunglasses: or copy/pasted text

Thank you brother for the help, I removed the second picture.
I found the option you mentioned and changed it, thank you. Is there any way to test if it works or not? Because I want to unblock the connection in the Discord program.

do not use screenshots of text - provide context in writing

I want to change dns instead of using VPN

cat /etc/resolv.conf
should do it

I don’t know what that means.
A DNS server simply translates the human readable domain names into numeric addresses.
Nothing will change - except perhaps when your provider filters some queries out (to protect you for whatever or to try to prohibit you from access to whatever - then an external DNS server can circumvent this)

Thank you bro it worked but i need it on gnome

I did describe the logic - you’ll figure it out.
I think it’s the first screenshot.

My need to change dns is to unblock some program features such as Discord, which is blocked and only works with VPN.

a vpn is something very different
dedicated servers which, among other things, do not rely on whatever DNS server you have set
they give you their own

no one want’s a DNS leak - a vpn which uses an untrusted nameserver

1 Like

So the use of VPN is unavoidable ؟

Of course not. You followed a tutorial for Ubuntu / CentOS.

On Manjaro, both openresolv and systemd-resolvconf provide resolvconf, however neither provide the service the video is referencing.

Either way, you don’t need either since NetworkManager already handles DNS. In fact, you can remove openresolv.

Then why did you originally post this in Xfce? Since it was a networking issue, I moved it to Network xfce earlier. Apparently I’ll have to modify the tag appropriately–again.

Please create a new topic regarding that as it is a different subject.

In the future, please copy and paste terminal output instead of taking screenshots.

1 Like

thank you bro i will :heavy_heart_exclamation: :heavy_heart_exclamation: :heavy_heart_exclamation:

I don’t know why it would be necessary to use a VPN to use discord.
But then again: I don’t even know from experience what Discord is …
I thought it was some kind of chat server. :man_shrugging:

Yes, it’s a chat program with a servers.

discord

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.