Resolution of login screen customizable


I would like to adjust the resolution of the login screen when starting KDE. At the moment the resolution is simply too high due to my NVIDIA 4k graphics card, i.e. the display is too small.

Attached are my laptop details

  Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.5
    Distro: Manjaro Linux
  Type: Laptop System: LENOVO product: 20H9001EGE v: ThinkPad T570
    serial: <superuser required>
  Mobo: LENOVO model: 20H9001EGE v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N1VET63W (1.53 )
    date: 12/20/2022
  ID-1: BAT0 charge: 27.4 Wh (100.0%) condition: 27.4/32.0 Wh (85.6%)
  ID-2: BAT1 charge: 19.3 Wh (100.0%) condition: 19.3/24.0 Wh (80.5%)
  Info: dual core model: Intel Core i7-7600U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 2825 min/max: 400/3900 cores: 1: 2800 2: 2900 3: 2800
    4: 2800
  Device-1: Intel HD Graphics 620 driver: i915 v: kernel
  Device-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 525.89.02
  Device-3: Chicony Integrated IR Camera type: USB driver: uvcvideo
  Device-4: Chicony Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: modesetting,nvidia
    dri: iris gpu: i915 resolution: 2048x1152~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: Mesa Intel HD Graphics 620 (KBL
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Ethernet I219-LM driver: e1000e
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
  IF: wlp4s0 state: up mac: <filter>
  IF-ID-1: wwp0s20f0u6i12 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 447.13 GiB used: 53.37 GiB (11.9%)
  ID-1: /dev/sda vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB
  ID-1: / size: 438.03 GiB used: 53.37 GiB (12.2%) fs: btrfs dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 608 KiB (0.2%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 438.03 GiB used: 53.37 GiB (12.2%) fs: btrfs
    dev: /dev/sda2
  ID-4: /var/log size: 438.03 GiB used: 53.37 GiB (12.2%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) dev: /dev/sda3
  System Temperatures: cpu: 39.0 C pch: 37.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
  Processes: 220 Uptime: 26m Memory: 15.35 GiB used: 2.39 GiB (15.6%)
  Shell: Zsh inxi: 3.3.25

Hi @Sunshine,


(That’s what I found online.)

I think this intervention is more for advanced users.

You can first try applying Plasma Settings to SDDM (you can find that in System Settings - Startup and Shutdown - Login Screen (SDDM), and at the bottom of the window you’ll see the button to do this). Secondly you can try making changes found at SDDM - ArchWiki

In my /etc/sddm.conf file I have this that works for me:
ServerArguments=-nolisten tcp -dpi 100

I applied that, saved and rebooted and now the screen is all black and I can’t log in. What should I do now so I can log back in and undo this so I don’t have to reinstall everything again?

can you tty to a login prompt?
if you can login and use sudo nano to undo your changes.
I have never had that happen when I changed that setting.
I think you must have changed other things in addition to that change to cause a black screen.
I have had a black screen before and renamed the xorg.conf file and fixed the black screen I had.