[Résolu] Problème d'installation conflit GPU / CPU


#21

bon ca va pas être facile pour la suite
en gros il n’y a pas de drivers nvidia installé pour gérer la carte video

peux-tu me fournir le retour de

sudo mhwd -l -d --pci

#22

La commande ne me retourne rien comme la précédente…


#23

si tu vas dans Manjaro Settings
que propose-t-il en drivers videos ?


#24

Quand je vais dans Configuration du système/ Configuration Matérielle l’application ne répond plus. Donc je ne sais pas si il propose des drivers vidéos.


#25

parce qu’elle s’appuie sur ces commandes du coup on a la même chose
bon on va essayer autre chose
( note ton mdp avant pour accès manjaro.org )

tu vas redemarrer avec la clé USB install
en EFI avec la commande acpi_osi=! acpi_osi=“Windows 2009”
et tu selectionne non-free drivers

tu démarres sur la clé et tu me retourne
inxi -Fxxxz

ainsi que l’ecran proposé sur changement de drivers
tu sera pour l’instant sur le live USB , c’est pour verification


#26

D’accord je fais ça en début d’après midi. Mais en EFI c’est a dire ?


#27

que tu selectionne bien sur la clé USB avec un numéro de partition proposé affiché
on le verra bien avec le retour de inxi


#28

Bon j’ai essayé plusieurs fois, je crois que linux ne veux pas de moi… Le lancement du live s’arrête sur :

[ OK ] Started TLP system startup/shutdown


#29

ok tu retentes avec démarrage USB install
direct en non-free sans ajouter la commande ( pas de modification )


#30

J’ai réussi a booté en free mais en non-free je bloque toujours au même endroit et mon pc ventile beaucoup.


#31

alors c’est là qu’il y a un serieux problème ,

je vais t’expliquer en gros les differents drivers gere par manjaro
on a en libre
drivers intel
drivers nouveau
drivers vesa
et
non libres
nvidia ( 2 series )
et nvidia-bumblebee

le probleme que tu rencontre est le suivant : au démarrage tu n’est pas completement sous EFI , il y a des options qui se sont lancés et qui bloquent la ressource ( ici la carte nvidia ) , on ne parviens même pas a dialoguer

en install free , driver au demarrage intel et associé a nouveau , malheureusement pas de gestion , ni même de reponse , d’ou les blocages sur l’accès mhwd dès que cela concerne nvidia

en install non-free , idem pour le même souci , tu n’a pas la gestion correcte de la carte nvidia ,
et donc tu n’as pas la suite

tu peux verifier avec inxi -Mxxx
tu devrait être en EUFI et non EUFI[legacy]

si tu as toujours le legacy , il y a une option dans le bios qui a forcé le démarrage , ce n’est plus de EUFI c’est la mauvaise cuisine au niveau du Bios

tu peux essayer en anglais , mais pas sur que l’on parvienne a resoudre le probleme
voir aussi sur Archlinux ou forums , pourtant le portable ne devrait pas poser de soucis

il reste aussi a voir la maj Firmware pour le Bios

en état c’est le couple ( bios , nvidia ) qui pose souci

tu peux tenter en non-freepour voir si cela passe mais j’ai des doutes avec
acpi=off
acpi_osi=! acpi_osi=“Windows 2012”
acpi_osi=! acpi_osi=“Windows 2015”
acpi_osi=!


#32

D’accord, je vous remercie pour toutes ses explications. Dans un premier temps voici le retour de la commande inxi -Mxxx

$Machine:   Type: Laptop System: ASUSTeK product: G551VW v: 1.0 serial: G1N0CJ021162034 
           Mobo: ASUSTeK model: G551VW v: 1.0 serial: BSN12345678901234567 UEFI: American Megatrends v: G551VW.206 
           date: 11/13/2015

Je suis bien en UEFI et non en Legacy.

Je vais essayé dans un premier temps si j’arrive a booté avec les paramètre que tu m’as fourni puis j’installerai.
Si ce n’est toujours pas concluant j’irais mettre à jour le BIOS.
Si celà ne donne rien non plus j’irais sur les forum de Archlinux et je posterai ma situation.

Mais je tenais à vous remercier pour toutes les explications fournies. =


#33

absolument deconseillé , les topics ne sont acceptés que s’ils fournissent le detail des erreurs ,
si c’est pour l’aide a l’installation , ils considerent que tu est le maitre abord
( Archlinux s’intalle comme les 1eres versions de Gentoo avec toutes les étapes manuelles à faire … )

je parle bien du forum manjaro.org , par contre si tu trouves des indications ou infos oui cela peut être utile


#34

J’ai réussi à booté en non-free acpi=off, le clavier et le pad ne fonctionne pas mais voici la configuration matérielle


#35

Ok très bien!


#36

donc c’est bien un blocage par le bios au depart qui empêche la gestion correcte de la carte Nvidia.
on ne pourra pas faire grande chose sans clavier ,
car ce que tu vois c’est la situation à partir de la clé USB et non de ton disque installé

possible que cela soit lié a X - bumblebee - input qui de ce fait ne retrouve plus le clavier / pad

en gros , tout n’est reconnu immediatement après installation , ni même avant …


#37

D’accord mais ducoup, il me reste quoi à faire?


#38

alors c’est le plus fastidieux
trouver les bons mots clés pour demarrer le noyau avec le clavier / pad et Nvidia reconnu ,
car tu pourra l’ajouter dans les options de grub au demarrage
https://wiki.archlinux.org/index.php/Libinput
https://wiki.archlinux.org/index.php/Touchpad_Synaptics
https://wiki.archlinux.org/index.php/backlight


#39

Ok donc la je vais refaire l’installation avec non-free, acpi=off (j’utilise mon pc avec un clavier et une souris externe) il faudra que je trouve les drivers de mes ses périphériques? ou alors que je recherche quelles commandes je peux ajouter dans le boot à l’installation pour que mes périphérique soient reconnu?


#40

mets alors

inxi -Fxxx

essaye primusrun nvidia-settings
ou
primusrun nvidia-smi