Resilio Sync (Home) Installation

Last night I was trying to know how to install software in Manjaro as I’m new to Manjaro and Arch. (here). and user Yochanan helped me a lot.

Resilio was installed and ran instantly, but now same link in browser I get “Unable to connect”

I tried install, uninstall… commands… I couldn’t!

I’ll really appreciate if you can help me install and run smoothly and have the service auto start even after restart.

Thank you.

If I remember correct resilio sync is a commercial p2p sync network.

In any case resilio support should be contacted.

FLOSS alternative to Resilio Sync is SyncThing

Resilio Sync started as btsync and went commercial - then it was forked as SyncThing - so essentially SyncThing is Resilio Sync without the privacy issues.

1 Like

Thanks linux-aarhus

First, apologies if I shouldn’t have posted here.
Secondly, I’ll have a look at syncthing, though it is not available for iOS (though ther’s is an app in iOS that uses it.).

I’ll check with resilio support (I already have it on 3 other devices, 2 x iOS.and 1 Windows which I hopefully convert it soon to Manjaro)

Thanks a lot


1 Like

There is a wiki for Resilio Sync

I don’t know if this work but it says you need to enable and start the rlsync service as user,maybe you need to do that?

systemctl --user enable --now rslsync

Thanks a lot XRaTiX

Your link gave me a lot.

Actually I kept trying and reading, what I did was mainly (copy/Paste from Konsole some of the output during installation):

to reload system systemd modules:     systemctl daemon-reload
      to start rslsync manually:             systemctl start rslsync
      to autostart rslsync on system start:  systemctl enable rslsync


      to reload user systemd modules:       systemctl --user daemon-reload
      to start rslsync manually:             systemctl --user start rslsync
      to autostart rslsync on user login:    systemctl --user enable rslsync

      Didnt work:
      User instance MUST be configured before use. To perform configuration,
    install rslsync-autoconfig package or follow manual configuration steps:

        1. Copy /etc/rslsync/rslsync.conf to ~/.config/rslsync/rslsync.conf for
      the user you wish to configure rslsync:

        mkdir -p ~/.config/rslsync
        cp /etc/rslsync.conf ~/.config/rslsync/rslsync.conf

      2. Replace user-specific references with the appropriate information,
      including the following settings:

        - storage_path
        - pid_file
        - webui.listen
        - webui.login
        - webui.password

      3. Make sure folder you specified as storage_path and folder where pid_file will
      be located both exist in the filesystem, since rslsync will not create it for you.

and some other tweaks from here and there.

It is working now (sort of), still indexing files, but I can’t see any peers yet though they are connected!

I’ll follow up and keep you posted.
Thank you.

Apologies for replying to myself. I’m new here! Sorry!

A few things I don’t understand.

  • it appears to me it finished sync but says “Not synced yet”
  • there are no peers

The way I added the folder was through a key not a link that I got from another peer my iPhone. When Added the key here it gave me the folder name exactly as on other peers.
On this laptop when I try share the folder it gives me the same key. So I believe I didn’t initially put a wrong key.
Why not synced yet? Why no peers?


To update you as I promised.

It seems to be a bug in Resilio.

I removed the folder then added it via link (not key as before).
Once added I saw other pears instantly!

linux-aarhus and all of you,

Thanks a lot linux-aarhus for mentioning syncthing :vulcan_salute: :+1:

Just to update you what happened since then.

  • I played a while with resilio, (I noticed my laptop was not that responsive -worse than old windows actually - as before with resilio).
  • for some reason I couldn’t reboot, tried to fix, no way! So, I reinstalled. didn’t install resilio, laptop was responsive and perfect.
  • I installed syncthing on this laptop and on the other one running windows. Made both run sync upon boot.

I still have resilio on other laptop and both iOS devices (no syncthing for iOS, only payable app, PLUS resilio allows for selective sync and on the windows laptop I have 1TB external USB)

So, now, and thanks to syncthing I really have my own 1TB cloud that I can access from any of the laptops, any of the 2 iOS)

Thanks again for mentioning syncthing. :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.