Request: please disable bell in lightdm

One of the most annoying things I have to face is the bell sound when the password field is empty and I press backspace in lightdm (using xfce). I’ve disabled it with the following line in /etc/lightdm/lightdm.conf

greeter-setup-script=xset b off

I want to make this part of the default install as I can’t think of any good reason why you would want such horrible sound to be accidentally played during login. The only way I can think of is having an overlay for that file here:

Downside is you have to overlay the entire file (afaik). Unless you can suggest a better way. I’m willing to do the work and provide the patches if you are OK with this.

You probably should contact the lightdm developers with this request. Here maybe? GitHub - canonical/lightdm: Display Manager

An audible sound when the field is empty could be invaluable to impaired people.

You could try disabling the assistive tools which are default enabled.

You do it using the Login Manager application

Truth be told… I almost always keep all sound off. :shushing_face:

That should be the special case, not the default.

1 Like