Replace eudev-systemdcompat with community/eudev-systemd and libeudev-systemd?


#1

During a system upgrade I get the following message:

   Starting full system upgrade...
:: Replace eudev-systemdcompat with community/eudev-systemd? [Y/n] n
:: Replace eudev-systemdcompat with community/libeudev-systemd? [Y/n] 

I said no and the upgrade worked just fine. It seems that the problem is with upower-pm-utils according to this link http://bbs.archbang.org/viewtopic.php?id=5740.

Any idea what I should do?


#2

I’m running XFCE OpenRC and replaced eudev-systemdcompat with eudev-systemd and libeudev-systemd with no problems.

I don’t have upower-pm-utils installed (upower and pm-utils instead).


#3

Well, I tried to let pacman do its thing but then I got this message:

:: Starting full system upgrade...
:: Replace eudev-systemdcompat with community/eudev-systemd? [Y/n] y
:: Replace eudev-systemdcompat with community/libeudev-systemd? [Y/n] y
warning: gtk2: local (2.24.30+95+g876b5f7-1) is newer than extra (2.24.30-3)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: upower-pm-utils: removing eudev-systemdcompat breaks dependency 'eudev-systemdcompat'

I do have upower-pm-utils installed but it is installed through yaourt and not pacman. When I tried to remove it I could not because of some dependencies.

yaourt -R upower-pm-utils
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: kdelibs: removing upower-pm-utils breaks dependency 'upower'
:: light-locker-upower: removing upower-pm-utils breaks dependency 'upower=0.9.23'
:: solid: removing upower-pm-utils breaks dependency 'upower'
:: xfce4-power-manager-upower: removing upower-pm-utils breaks dependency 'upower=0.9.23'
:: xfce4-session-consolekit: removing upower-pm-utils breaks dependency 'upower=0.9.23'

#4

Remove upower-pm-utils, install upower and pm-utils and try again.
upower-pm-utils is not in repos any longer since some time.


#5
pacman -S upower pm-utils

Say yes for replacing.


#6

I replaced upower-pm-utils which uninstalled loads of packages and then installed upower pm-utils and since then, Suspend doesn’t work. What did I forget to re-install???


#7

Like described here?
https://bugs.manjaro.org/index.php?do=details&task_id=26

I switched back to linux41.


#8

But there must have been something in the upower-pm-utils that isn’t in the upower and pm-utils packages??? What’s the difference? I am on Linux47 now but Suspend wasn’t an issue since linux44 or something like that (I cannot remember back that far :wink: )


#9

What DE?
Notice, upower-pm-utils is not in the repos, and I had it also removed from AUR. Its an older version of upower.


#10

LXQT 0.10.0


#11

yes, lxqt doesn’t have proper power management yet for non systemd, it only works with systemd atm. But thats DE specific.


#12

hmmmm, strange that it worked before I removed upower-pm-utils… I have been toying with converting to either plasma or XFCE DE…


#13

Its not strange, upower upstream removed pm-utils support, but in turn, consolekit gained some of these. However, lxqt is exception unfortunately. You could try with elogind(you need to build it yourself), it will work, but notice, elogind is also no full replacement for what consolekit does.
elogind basically just provides logind interface, but no VT management.
ck will gain logind interface at some point I think, likely in time when distors switch to wayland.


#14

LXQT is not the only DE which won’t suspend/hibernate without upower-pm-utils; I had decided to drop it for upower and tried all combinations of upower+pm-utils+mate-session-manager (even compiled upower with --enable-deprecated) and it just wouldn’t work. Went back to upower-pm-utils+mate-session-manager-upower and, well, profit! I’ll re-upload it to the AUR, updating depends to eudev-systemd.

[EDIT] I’ve ldd’ed binaries and libraries and didn’t find any shared dep on libsystemd; namcap confirms eudev-systemd as not needed.


Cannot update on Manjaro Openbox 0.8.6 install - elogind, pm-utils, systemd
#15

I think upower + pm-utils works with Xfce because xfce4-session-manager handles the dbus calls to suspend / hibernate, and then passes it off to pm-utils to do the actual procedure.

upower-pm-utils had its own code for suspend / hibernate AFAIK, and mate-session-manager or lxqt-session-mamager likely can only talk to upower or systemd, hence fail with upower + pm-utils.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.