"Replace a partition" is not available

replace

#1

“replace a partition” option is not available when i am trying to install manjaro alongside the win10
My disk is gpt


#2

Do you have a partition available to replace?


#3

Yes I have made 25Gb uncollected


#4

That’s “free space”, not a partition (hence you can’t “replace” it).

Create a partition in that free space and install Manjaro as normal.

(Please also keep in mind that high-resolution photos aren’t always the best way of providing a screenshot - there should be a dedicated screenshot tool on the live image.)


#5

I have also created a partition and got the same result
Besides I have install manjaro on free space before successfully


#6

OK, then I don’t understand the problem.

Can you be more specific about the problem you’re having?


#7

I’ve installed manjaro without problem
I have got win10 and manjaro on my laptop
But I decided to reinstall win10 and manjaro
After installing win10. I started to install manjaro and faced with this problem


#8

This is the bit you need to be more specific about.

You said you installed to “free space” before - why can’t you do the same this time?


#9

The “replace a partition” was available before
But now it’s not
I just simply replaced the free space with manjaro


#10

OK, so select the free space, Create a new partition, and install Manjaro onto that new partition.


#11

I have tried to create swap and boot/efi and root
That is alright
I have just given up the win10
Now I am erasing the disk and install manjaro, solo boot


#12

Ah, right, it would make sense why you can’t do that.

It looks like you’re using an MBR disk. You already have three of four primary partitions so you can only create one more (unless you use Gparted and create an extended partition, then you can create several extended partitions within it). If you’re booting in BIOS/Legacy mode (which I assume you are because you have an MBR disk) you do not need an EFI partition.

I think that’s the ideal solution. No more Windows. :laughing:


#13

The best solution ever