Removing week numbers from the Xfce calendar

Is there a way to remove the week number count from the calendar in the tray ? I can't find it.

What calendar app are you using?

here is the info on using a custom date format for the xfce clock.

(i assume you're using xfce from a past post of yours. you really should add your de to your user profile for future use, or specify it in your questions.)

2 Likes

I am using the original XFCE clock/calendar. It is not in the date format too. There is no calendar settings that I can find.

ah, i see what you mean. i don't know a way to do that. there IS a setting in dconf

org.gnome.desktop.calendar.show-weekdate

to control whether week numbers are shown, but i don't know if the xfce clock is supposed to be looking at it. if it is, and it's not obeying it, that would be a bug.

The command is accepted but has no effect. (from ubuntu)

gsettings set org.gnome.desktop.calendar show-weekdate false

yes, i know it's not. what i don't know is whether or not that's a bug.

I also didn't have any luck with the dconf setting.


What you're trying to do is possible if you're willing to use the Orage Panel Clock plugin instead of the default Panel Clock plugin.
After you add it to the panel, you can configure it so that the time/date format is the same as in the default one. You can also hide the week numbers in the calendar - once you open the calendar select Edit > Preferences > Calendar window (tab) and uncheck the option Show week numbers.

Just an alternative option you can try. :man_shrugging:

1 Like

now that you pointed it out, it's bothering me, too. this looks like it's set in the source code for the clock plugin:

https://git.xfce.org/xfce/xfce4-panel/tree/plugins/clock/clock.c

plugin->calendar = gtk_calendar_new ();
gtk_calendar_set_display_options (GTK_CALENDAR (plugin->calendar),
                                        GTK_CALENDAR_SHOW_HEADING
                                        | GTK_CALENDAR_SHOW_DAY_NAMES
                                        | GTK_CALENDAR_SHOW_WEEK_NUMBERS);

the clock plugin is part of the 'xfce4-panel-gtk3' package, which was packaged by @philm. (unless you're not using the gtk3 version, in which case it looks like we're getting it from arch.) phil's pkgbuild is here

save off the pkgbuild, pull down the source, edit clock.c, make and install.

(and restart the panel: xfce4-panel -r)

2 Likes

Thanks for hunting that down. It worked for me:

calendar

I created a patch to make it a little easier:

--- xfce4-panel-44d2d6badfeff9544bb1de7b2ad19af29a5a1113/plugins/clock/clock.c	2019-05-28 20:34:29.000000000 +0000
+++ xfce4-panel-44d2d6badfeff9544bb1de7b2ad19af29a5a1113/plugins/clock/clock.c.new	2019-06-12 17:37:26.144597348 +0000
@@ -1321,8 +1321,7 @@
       plugin->calendar = gtk_calendar_new ();
       gtk_calendar_set_display_options (GTK_CALENDAR (plugin->calendar),
                                         GTK_CALENDAR_SHOW_HEADING
-                                        | GTK_CALENDAR_SHOW_DAY_NAMES
-                                        | GTK_CALENDAR_SHOW_WEEK_NUMBERS);
+                                        | GTK_CALENDAR_SHOW_DAY_NAMES);
       g_signal_connect (G_OBJECT (plugin->calendar_window), "show",
                         G_CALLBACK (clock_plugin_calendar_show_event), plugin);
       g_signal_connect (G_OBJECT (plugin->calendar_window), "button-press-event",

But it's still not what you'd call "user friendly." It would be nice if they put in a GUI setting for this, but I wouldn't count on it.

2 Likes

Thanks bill_t, I tried the Orage Panel Clock plugin but didn't noticed the options of the calendar. That's what I want. There is a lot more options then the default clock/calendar so I ditch it.

Works for me ! Much better then recompile something :grimacing:

Orage panel clock; Line 1; %R

Now now that I got what I want, I have another one for you. I customize the Orage calendar by removing the windows decoration and the top MENU. So how can I get the calendar preferences again (no menu anymore) ???. I click every where, right click and holding shift, ctrl and double click but the damn thing won't reappear.

Short of re-installing. Who design that thing ???

Edit : I can' t find the way to do it but you can edit this config file and restore it.
~/.config/orage/oragerc

Right click it on the panel?

Great job @steanne !

After following your instructions...no more week numbers.

scrot_xfce_panel_2

Thanks for all the information! :+1:


You can run orage -p in a terminal window or use the Xfce appfinder that shows up when pressing Alt+F2 and run the command orage -p.

Yes that work if you r-click on the additional calendar icon but I got rid of it in the options since it`s kind of redundant.

"orage -p" work ok. Good find.

P.S I didn't know that so many people were annoyed by that useless pesky week count like me.

Annoyance equals ignorance (lack of knowledge & will to learn ) :neutral_face: