Removing i3lock due to laptop freezing up

Hey, I've been encountering an issue similar to the one on the following thread. Due to the thread never being solved, I've failed to scout a solution online. Could you possibly assist me? Thanks.

sudo pacman -R i3lock

Try to run xfce4-power-manager-settings and remove the lock when going to sleep option.

It is not ideal but could be a solution.

Laptop still freezes after going out of sleep mode. What could be the issue?

Are you using tlp?

It is recommended to disable rfkill if you are using tlp.

Have you tried setting up tlp using tlpui?

Are you referring to suspend (still powered - but only the minimal required to hold memory)

Or are you referring to hibernate (requires swap partition sized system+graphics memory) and a resume=UUID=xxx-yyyy-zzzz in grub default.

I'm not using tlp as far as I'm concerned. I'm fairly sure I'm referring to suspend.

Does your system power led blink during sleep/suspend?

Please install the package pastebinit then run this command

inxi -Fxxxxc0 --no-host | pastebinit

Then paste the resulting URL in a reply.

Nope, just the standard moon icon (I'm using a Thinkpad X200).

https://duckduckgo.com/?q=arch+linux+think+x200+lock+when+waking+from+suspend

That leads to this https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X200 and I don't see any sub heading about system locking up on waking up in the troubleshoot section. @altro I wish I had an update for you unfortunately I just got in the habit of rebooting. The issue for me seem to get more rare with better iterations of the 4.19 kernel I think.

Forum kindly sponsored by