Remove or disable "Suspend" button in Logout

In Xfce, how could I remove or at least disable the Suspend button in the logout popup (made of Log Out, Restart, Shut Down, Suspend, and Switch User).

Perhaps a word on motivation. I run my Manjaro Xfce as a guest in a VMware Workstation, and Suspend does not work. After a Suspend, I could only use VMware’s “Power Off” (which is not a nice shutdown but probably an equivalent of pulling the power cord) to get my Manjaro back.

I found posts on such topics as disabling sleep or hibernate, which is distinct from my concern. I only want to remove or disable the button. I am not going to go out of my way to suspend the machine. I just don’t want to be offered a handy button to do it. Thanks.

Right-click the logout-icon in the panel - properties - choose as you like.

Thank you. I’ve tried that. I could untick “Log Out…” and tick the ones I want (Log out, Restart, etc.). But I get a row of buttons (one per each), and this does not affect the Log Out button you get in the top-right corner of the Start menu (in Windows terms, I don’t know what it’s called in Manjaro).

xfconf-query -c xfce4-session -np '/shutdown/ShowSuspend' -t 'bool' -s 'false'

Hide Suspend and hibernate options / General discussion / Xfce Forums

1 Like

That did it! Thank you.

Just a note on anybody else trying it. It went:

  1. Run the command.
  2. See that in place of Suspend you got two buttons, Suspend Sleep and Suspend Hibernate, which look rather worse than before.
  3. Reboot.
  4. See that all Suspend buttons are gone. Only remaining: Log Out, Restart, Shut Down, and Switch User.


No, unfortunately, that didn’t do it. I see that, after a time, the two Suspend buttons come back.

xfconf-query -c xfce4-session -np '/shutdown/ShowHibernate' -t 'bool' -s 'false';
xfconf-query -c xfce4-session -np '/shutdown/ShowHybridSleep' -t 'bool' -s 'false'

remove “switch user” buttons from logout dialog & lockscreen / Desktop / Xfce Forums

1 Like

Thanks. Running both (or all 3) commands did it!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.