Remove Bluetooth *and* from system tray (Apr'22)

Basically the post here is unfortunately a combination of inconsistent and incomplete, or in the past months something has changed and they no longer work.

Although the below instructions show promise no longer appearing as complete.

I even tried to enforce the blacklisting with:

sudo modprobe --use-blacklist bluetooth
sudo modprobe --use-blacklist btusb

Yet when I press a physical (ie. on the computer itself) general purpose network button, and then run:


output alternates between “on” and “off (software)” between each push of the physical button.

I removed bluetooth first and thus there is no /etc/xdg/autostart/blueman.desktop file to even edit, as per the instructions. NOTE: I’d prefer not to simple “hide” something but for that something not to be sought in the first instance, though maybe this is just wishful thinking on my part.

Anyway a bluetooth icon appears in the tray depending on whether I run :

bluetooth on    # or
bluetooth off

Instructions to remove pulseaudio-bluetooth (and bluez, libical) are possible after removing manjaro-pulse like so

sudo pacman -R manjaro-pulse
sudo pacman -Rs pulseaudio-bluetooth

I have tried restarting(?) pulseaudio with:

pulseaudio --kill
pulseaudio --start

But that appear to do sweet nothings (not even the PID of the tray icon widget changed). So I tried resetting the entire panel with:

xfce4-panel -r

…and though the panel did refresh along with the PID of the widget, which was great, the bluetooth icon is still toggling into view.

What is the most basic way to remove bluetooth at this point?

The common way to disable it completely is at BIOS/UEFI Settings.

for the panel applet
LANG=C xfce4-settings-manager
go to “Session and Startup” → “Application Autostart
and remove the checkmark from the checkbox for the bluetooth applet.

then there is the underlying service - the applet just lets you control and interact with it
stop and disable the service:

systemctl stop bluetooth.service
systemctl disable bluetooth.service

the service depends on a few modules - maybe just blacklisting “bluetooth” isn’t sufficient?
I don’t know and will not test.
anyway, find out what other modules are related
and blacklist those too if blacklisting “bluetooth” isn’t enough:
Here is how to find them (example from my system):

lsmod | grep blue
bluetooth             909312  44 btrtl,btmtk,btintel,btbcm,bnep,btusb,rfcomm
ecdh_generic           16384  2 bluetooth
rfkill                 36864  7 bluetooth,cfg80211,sony_laptop
crc16                  16384  2 bluetooth,ext4

! do not blacklist all of those - some are needed by other things as well and may shoot yourself in the proverbial foot if you blacklist ext4, for example :wink:

After this, no bluetooth module will be loaded, the service will not start and the panel applet is also gone.

On my laptop I cannot toggle bluetooth separately in the Bios …

Thanks Nachlese, I blacklisted a couple extra modules.

After doing that the tray icon was still showing alternating into view as described in my OP. I decided to bite the bullet and see if a logout and login might solve the problem and it did.

So If you’ve tried everything above and still see the icon maybe you simply need to try logging in again. :slight_smile:


There is also a /usr/lib/bluetooth/obexd process that, according to systemctl, is in app.slice. I aim to get around to investigating and dealing with that too. Sooo many processes, yikes. There’s seems nothing on the forum, no man pages, and there are no packages that seem to relate to it, fwict. Found this on the archlinux wiki about it and it seems to be exclusively about bluetooth functions.

How to remove this obex/FTP thing? EDIT: seems to be part of gnome-vfs-obexftp so will determine how best to proceed later. I have no problem with some basic functions sitting idle in the system but when they are listed as active services I’m a bit taken aback, tbh.

Almost forgot to return to this topic.

Although it was loosely discussed in this thread (mentioned in the OP) the precise method is indeed to remove the ‘META’ package ‘manjaro-pulse’ but not the packages it installed. As a ‘META’ package it simply grouped together a bunch of other packages for install.

sudo pacman -R manjaro-pulse          # no 's', don't uninstall the
                                      #. orphaned packages that it
                                      #. suggested.
sudo pacman -Rs pulseaudio-bluetooth  # with 's', and orphaned. This
                                      #. will remove the 'bluez'
                                      #. package also.

If the ‘obexd’ package is still running you can kill it with:

kill -9 $(pidof obexd)

It should not appear again at startup.

Done. :slight_smile: