Remote license file not found. Any security blocks in Manjaro?


Not sure this is the right category but it seems to be the closest to my problem.

I’m trying to install STAR-CCM+ locally on my laptop and checking the license from the university server. Somehow I just can’t check out the license file even though it exist and can be reached from other Linux machines on the university network. The IT person assisting me successfully checked out the file from his home Windows machine and another IT person confirmed it. Same thing for my colleague on her Windows machine. I even tried with university VPN connected.

I can ssh to the server in question from home but telnet back to localhost (my laptop) is blocked.

Yesterday I went to the university and tried again using university wifi with no luck. I also tried on a wired connection with no restrictions from within IT department and could not check out the license file. However, when we tried from a university Ubuntu machine and a Windows machine everything worked fine.

Based on all the above we strongly believe that it has something to do with Manjaro settings. I do not have a firewall installed and systemctl status firewalld.service confirms that no such daemon is running. Is there anything else we need to (un)check? Does Manjaro have any builtin security blocks for what I am trying to do? I would be very grateful if someone could at least point us in the right direction.

Here are my installation specs:
Plasma 5.23.5
KDE Frameworks 5.90.0
Kernel 5.10.93-1-MANJARO with X11

Though neither should be enabled by default… I guess would check ufw or iptables

sudo ufw status
sudo iptables -S

It’s a flexlm type license file on the university license server that includes all the licensing information for the commercial software I want to use. The software installer needs to access this file to allow using the software. It says which software modules have been paid for and for how long they can be used and in which way (single seat, floating, single/multi-user, etc.).

It’s definitely not a self-signed-certificate.

ufw is not installed on my system but iptables is. I’ll run the installer again and check its output.

are you referring to this :

The first link is broken but I managed to find the file online.

That’s how you install a license server on your own machine, and it’s not what I’m trying to do. I need to give the software installer on my machine access to the license file on the university license server.

I already have the installation guide you posted and followed its instructions to the letter. This was confirmed by the uni IT who is responsible for starccm+

So after busting my chops for a week on this, they update the license server at the university and all of a sudden everything works fine! It’s good to have a thick skin I guess :neutral_face:

huh … so … uh … it was IT’s fault ?

(or I guess some form of your cache that was then kicked by the update?..)

No it was very much IT.

Other users were having other problems as well and I couldn’t access the license server even on the uni machines, connected to their network by ethernet. The only installations working were the ones installed a while ago.