Remote GUI sessions can not authenticate with policykit

Hi,

I’m hoping someone could help me.

On a completely fresh install of Manjaro ARM (Raspberry 4), I get these Policykit errors:Screenshot_20201106_172203|327x361

This happens on both the XFCE Image and KDE Image. The Wifi error pops up automatically every 60 seconds or so, probably when some background service does a wifi-scan? Typing in the password doesn’t do anything. Pressing the network settings also causes the error to pop up.

Every install is a completely fresh system (I have tried several times). I set up the image via headless ssh. Once the setup script completes and reboots I log in and literally the first thing I do is via ssh install the remote desktop package. I have tried TigerVNC, X2GO and Xpra (on separate fresh installs), logging in works fine, I get the desktop and can remote it but the errors make the system unusable.

The only difference between the KDE and XFCE editions I have found is that installing a package via Pamac on KDE just fails with a policykit error, I never get the password prompt. On XFCE installing packages graphically actually works though. Maybe this difference could be a clue that could lead to a fix?

The two biggest desktop environments are therefore completely broken on Manjaro ARM when connecting remotely using very well established remote desktop protocols like VNC and X2GO (and the less known xpra).

What surprises me is that no one else seems to get this error? Is no one using remote desktop with their raspberrys? Or is the ARM version not used by anyone?

Any help would be really appreciated, I have been trying for a long time now, nothing works.

I don’t see any error. Just the Wifi password prompt…

We don’t test with Remote GUI sessions. And we have no such issues on regular setups with monitors and peripherals.
Why do you need a GUI on a system, that has no monitor. What’s the benefit of that?

Yes perhaps I worded it wrong, I apologize.

The problem is these prompts pop up constantly, typing the password doesn’t do anything. Just clicking on network settings makes this prompt pop up, it doesn’t accept any settings.

Also when using pamac this error pops up when you click apply

I never get the password prompt, it just fails.

Ah okay.

You say you use remote GUI. Why is that?

Isn’t the Raspberry PI widely used as a server? Surely regular desktop users are probably a minority compared to Raspberrys used as servers! The whole point is I want to be able to have a small compact and quiet system hidden away, not having to have a screen, keyboard and peripherals taking up space.

Some of the applications I need require X and generally speaking managing the server is just easier than having to use ssh for everything (even if I could which I cant).

It often is. Which usually means headless (no GUI).
But Manjaro is more a desktop focused distribution.

I am wondering if an x86 machine will have the same issues, if you re-create the same setup with one of those.

PS: Maybe this can give a hint to a possible solution for you:
https://wiki.archlinux.org/index.php/TigerVNC#"Authentication_is_required_to_create_a_color_managed_device"_dialog_when_launching_GNOME_3

Thank you for taking the time to answer.
Now that I know that Manjaro does not support remote desktop solutions I won’t try to make it do something it wasn’t designed to, I’m not familiar enough with these kind of deep down system settings.

I would add though, you say that Manjaro is a desktop focused distribution and that is what I am trying to use it as (albeit remotely). Essentially I wanted a 24/7 desktop where I could have torrents and other stuff running so I don’t have to run my main machine 24/7. Sure you can do that headless, but you know, I wanted a desktop. I think you may be underestimating how many people use raspberrys with remote desktop.

But, having said that, it is your operating system and I respect that you decide its functionality as you see fit. Though I would suggest that you at least add a message on the release pages that remote desktop isn’t supported, I think a lot of people naturally assume that a modern OS supports remote desktop applications.

Don’t get me wrong. It would be great if we could get it supported.

But to get that we first needs to know if Manjaro x64 supports it. If it does, then we can see what they do differently to achieve that.
If it does not support it, then it’s a bigger issue. Probably with the way policykit handles displays.

I am a little confused, since you can ssh to it, this must be over ethernet cable.
Why are you bothering with wifi?
Unless you’re using a crossover cable, the box must have internet thru your router?
Anyway, vnc can work fine thru ethernet cables, so ???
ifconfig OR ip a ; ping google.com

It’s not that the rpi does not have internet.

It’s the fact that policykit asks for password and fails to authenticate every minute, because it’s scanning for wifi networks.

Well then, turn off wifi?
sudo ifconfig wlan0 down
or nmcli r wifi off ,.,., or with systemd
For that matter, if you have 2 connections to the net, I would think that
they would have to be explicitly configured to work properly
But, thinking a moment, I have 2 connections, but 1 is to 192.168.1.
and the other to 192.168.2.,., and unless it fails, only the first is used
How it was setup, i don’t know, it just worked, not a systemd machine, a pearl script

But wifi is not the only issue.

It’s only that policykit just straight up fails to authenticate, because it does not ask the password it’s suppose to, when doing actions that require it, like installing/updating packages with Pamac.

Yes, Strit is correct, most if not all Policykit authentication requirements fail. Either by showing a prompt that doesn’t accept the password and just reappearing over and over again or by just failing without showing the password prompt at all and saying authentication failed, like in the picture above with Pamac.