[rEFInd] [testing] [5.9] After installing the latest testing update, systemd gets stuck at plymouth

Hi everyone!

Boring stuff here:
I reinstalled Manjaro after discovering the bioluminescent “guests” living in my previous Win10 installation, i decided to make Manjaro my daily driver. I already tried in the past for a good month but then decided to go back to windows (for some games), and to now settle for the good ol’ Jaro

the actual problem:
A few days ago i did sudo pacman -Syu and after restarting it wouldn’t even detect the installation.
After a third reboot it magically did, but now, as i said in the title, it would just hang on to plymouth.
Some details worth mentioning:

  • My GPU is a RX570
  • The cursor is visible in the systemd screen and fully functional. Imho this seems to suggest that the login is successful but some process can’t get terminated.
  • I tried downgrading to a LTS kernel (5.4) via live boot, chrooting into my installation, and going to the pacman cache to pacman -U <kernel-package>
  • I also tried to disable plymouth altogheter, but the nothing, it would still get stuck to some other process i can’t remember.
  • My FS is BTRFS, but sadly i didn’t make any snapshot because i’m dumb.
  • Lastly, but i’m pretty sure this is not the culprit, before updating, i changed my default shell to Fish. I did revert to bash, but nothing changed.

Any amount of help is greatly appriciated.

The process you cannot remember is important in this case. You should have seen many [OK] in green text rolling down your screen, then something that halted the process. Please let me know what that is. If you are still seeing the Manjaro logo then please try hitting esc during boot.

Oh also here’s some extra info i forgot to upload:

Here’s a journalctl log