Recover manjaro after installing openSUSE

Hi,
I just installed openSUSE Tumbleweed, on top of my existing Manjaro and Windows installs.
After installing, I booted into openSUSE and everything worked well, but then I rebooted to go into manjaro and it threw me an error at GRUB. The error said:
error: file '/boot/vmlinuz-5.9-x86_64' not found
error: you need to load the kernel first
I’m not really sure why this happened, since while I was installing openSUSE, I didn’t touch anything related to Manjaro, well maybe just the EFI partition, but I didn’t format it, I just told the installer to mount it as /boot/efi, on openSUSE of course
How can I fix this?

Manjaro needs manjaro’s grub unless you do some witchery.

Manjaros grub can boot everything else, but if you install another system and its grub as well, overwriting manjaros grub, then manjaro will struggle to boot.

You should probably follow one of the methods here:

Then you will need to reinstall and update grub.

1 Like

If you did that; no wonder ofcourse.
But you probably meant “aside of” as in next to…

If you installed both side-by-side then your Manjaro partition should still be accessible via a LiveUSB.
In cases like these i love to be using sd-boot, but that’s another bootloader…

You should probably post a tree output of your ESP., so we can check if things can be fixed…

The grub versions should have been installed in different locations inside the ESP.
Maybe the OP is using the default loader under $ESP/EFI/BOOT/… in which case nothing is lost yet…

Well, I have an update, I managed to get the manjaro grub back, following the guide on the official wiki (Though, the manjaro-chroot automatic mount didn’t work, maybe because my root partition is btrfs? It gave me the You can't mount #! error, I tried every number from 0 - 9 but didn’t work).
But I’m still having a little problem, the openSUSE entry doesn’t appear on my grub, and if I run the update-grub command, it appears to be detected:
Found openSUSE Tumbleweed on /dev/sda8
But when I reboot my system, it doesn’t seem to be in the grub menu, don’t know what’s causing this.

And also thank you for your replies :slight_smile: