Recover external HDD overtaken by ISO image

Got a 2TB external HDD, put some hundred MB’s of perosnal data on it (photos, videos), plus a few backed up video DVD ISO files. My daugther wanted to see a video DVD, and ultimately messed up something badly.

When I connect the hard drive to a computer, it mounts and plays as a normal Video DVD. When I check with Gnome Disks or GParted, it seems all 2TB’s are taken by the UDF partition, however, when I open it in the file manager, it says 5.5 GB are taken (regular video DVD files), and 0 bytes are free.

I have zero clue what caused this, and my daughter wasn’t able to tell me either. Is there any way I can restore my data? Any help would be appreciated, I’d hate to lose those memories :cry:

Hi @sajo, and welcome!

Have a look at Testdisk. It once saved over 2 terabytes of data for me. And I once used it to recover some dataa of the in-laws.

Thanks for the tip @Mirdarthos, I’ve tried Testdisk, but I’m not getting any progress. It doesn’t recognize the correct partition table type (“None” in auto mode), and after Quick and Deep Scan it still can’t see any file system. I kind of forgot how the HDD was formatted initially, but my take is that I just simply left it as it was originally (NTFS?). Yet when I set it to NTFS in either Intel or EFI GPT mode, I don’t get any results on scan. Am I missing something?

Hi @sajo,

I have no idea if you possibly missed something or not. But I can tell you that it’s the limit of my knowledge. I don’t know anything more, I’m really, really sorry.


Just me confirming that you’ve followed the instructions on the Testdisk website as close as possible??? Because, I didn’t the first time and it didn’t work either. Then I tried again , following those instructions, and it worked.