Recording screen on wayland does not work

I can’t record my screen. If I try to set this option like use default shortcut shift + alt + ctrl + R it does not work, I have changed it even and still nothing. I can see that I do not have that kind of option in ‘screenshot menu’.
I also tried with Kooha but program starts but if I would like to record it crashes (need to force quit).

I have AMD graphic drivers on wayland and if it possible I would like to stay on wayland.

Please describe what do you want to achieve

  1. What software do you want to use
  2. purpose (record screen is one thing and screencast is another)
1 Like

If you just want to record the screen, try SimpleScreenRecorder. It is available in the (community) repositories. Small footprint and as the name implies, it is easy to use.

1 Like


I run Gnome on wayland and when trying to recreate the situation you describe I can record video with the same tool. Why it does not let you do the same I cannot tell from the info supplied. I can choose video where your mouse is in the screenshot. Please read this the thread below and supply system information and if possible the relevant parts of the journal.

Edit: Pressing v switches between screenshot / screencast for you, does this work for you?

1 Like

Have you checked the log when trying to record?

Opening the terminal and running journalctl --follow and starting the recorder output anything informative?
In my situation the following is the only thing I can trace in the log are these lines

dbus-daemon[1630]: [session uid=1000 pid=1630] Successfully activated service ‘org.gnome.Shell.Screencast’

Alternatively trawling the entire log for the current sessions is an option and fitering for the screencast:
journalctl --boot | grep 'org.gnome.Shell.Screencast'

Adding your system information to the first post will help get better feedback & support for the issue. It will also help other with similair problems find this thread later if it is solved.

Please share it formatted as detailed here

1 Like

You can use OBS Studio to record your screen. I use Manjaro with KDE Plasma and Wayland on amd gpu and it works fine.

1 Like

@Hanzel it worked pressing v swithces screenshot / screencast, but it didn’t work anyway.

Thanks everyone for helping me. The solution was:
removing package related to intel where I use AMD…: xf86-video-intel, vulkan-intel, lib32-vulkan-intel.
While using AUR download OBS Studio want to use intel by default, so be aware! :slight_smile:
Everything works fine.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.