Recent NVidia driver upgrade broke Guild Wars 2 (Lutris launcher)

This is a cursed laptop: Lenovo Legion with two video adapters: Intel and NVidia. It never worked well to begin with: the dual-purpose drivers installed with mhwd could never work with the external display, and so I needed Optimus to switch to NVidia’s GPU. Surprisingly, it was also the same if I swapped them for video-nvidia driver (I assumed that it would just totally ignore the Intel’s GPU, but, I guess, the description in the manual is not so great).

Unfortunately, I don’t know how to diagnose the error: there are way too many moving parts involved, so, I’d appreciate your help in, at least trying to find where to look for the error.

Superficially, the game sort of launches… well, not quite, it sometimes gets to the login screen, sometimes it freezes a bit earlier. Sometimes even the graphics of the login screen are botched (partially loaded, it seems). At which point the laptop starts spinning its fans and all the GUI freezes.

At the minimum, I’d appreciate some help at restoring the older versions of GPU drivers. It also looks like mhwd didn’t do its job well in my case, so, probably let’s just (un)install the necessary packages instead?

Ideally, I’d like to get a better understanding of the problem: there’s just so many layers between the application and the GPU that I’m getting totally lost when trying to investigate it on my own.

inxi -Fazy
mhwd -li -l

That will be difficult - rolling

Sorry, the forum engine’s parser is buggy and it sees “links” in my reply, even though there aren’t any. I tried to guess what got it confused, but I couldn’t. So, I’ll post the reply here: https colon slash slash pastebin dot com slash qLeuFRve .

Maybe the mods can figure out the problem and move the text back into this thread.

inxi -Fazy
  Kernel: 5.15.146-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/ vmlinuz-5.15-x86_64
    root=UUID=be6e30e4-e93e-4d61-9c2f-7b4d61c2c954 rw udev.log_priority=3
  Desktop: GNOME v: 45.3 tk: GTK v: 3.24.39 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 45.0.1 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: LENOVO product: INVALID v: INVALID
    serial: < superuser required > Chassis: type: 10 v: INVALID
    serial: < superuser required >
  Mobo: LENOVO model: INVALID v: NO DPK serial: < superuser required >
    part-nu: LENOVO_BI_IDEAPAD8J_BU_idea_FM_IDEAPAD uuid: < superuser required >
    UEFI: LENOVO v: 8JCN43WW date: 07/18/2018
  ID-1: BAT0 charge: 46.9 Wh (100.0%) condition: 46.9/52.5 Wh (89.3%)
    volts: 12.6 min: 11.4 model: CPT-COS L17C3PG1 type: Li-poly serial: <filter>
    status: full
  Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 9 MiB desc: 1x9 MiB
  Speed (MHz): avg: 894 high: 1933 min/max: 800/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1933 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 52815
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: none off: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo
    driver: nvidia v: 470.223.02 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-01; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s ports: active: none off: HDMI-A-1
    empty: DP-1,DP-2 bus-ID: 01:00.0 chip-ID: 10de:1c8d class-ID: 0300
  Device-3: IMC Networks Integrated Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:4 chip-ID: 13d3:56a6
    class-ID: 0e02 serial: <filter>
  Display: x11 server: v: with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: not-matched mapped: HDMI-0 pos: primary res: 1920x1080 hz: 60
    dpi: 82 size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: not-matched mapped: eDP-1-1 size-res: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: iris
    surfaceless: drv: swrast x11: drv: nvidia inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 470.223.02
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1050/PCIe/SSE2
    memory: 3.91 GiB
  API: Vulkan v: 1.3.274 layers: 8 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 1050 driver: nvidia v: 470.223.02
    device-ID: 10de:1c8d surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0fb9 class-ID: 0403
  API: ALSA v: k5.15.146-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
    vendor: Lenovo ThinkPad E595 driver: rtw_8822be v: N/A modules: rtw88_8822be
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 07:00.0
    chip-ID: 10ec:b822 class-ID: 0280
  IF: wlp7s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
  Device-1: Realtek RTL8822BE Bluetooth 4.2 Adapter driver: btusb v: 0.8
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5
    chip-ID: 0bda:b023 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 4 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 1.14 TiB used: 319.28 GiB (27.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB256HAHQ-000L2
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 0L1QEXD7 temp: 35.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: LCM2 scheme: GPT
  ID-1: / raw-size: 238.18 GiB size: 233.38 GiB (97.99%)
    used: 164.72 GiB (70.6%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 59.0 C pch: 55.0 C mobo: N/A gpu: nvidia temp: 50 C
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.5 GiB used: 2.74 GiB (17.7%)
  Processes: 324 Power: uptime: 21h 47m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 1 hibernate: platform
    avail: shutdown,reboot,suspend,test_resume image: 6.19 GiB
    daemons: upowerd,gsd-power Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1787 libs: 505 tools: gnome-software,pamac
    pm: flatpak pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.32
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-470xx            2023.03.23               false            PCI
     video-modesetting            2020.01.13                true            PCI
Warning: No installed USB configs!
> 0000:08:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI
> 0000:01:00.0 (0300:10de:1c8d) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
> 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

As for the later, I tried a bunch of different settings, including video-nvidia and video-hybrid-intel-nvidia-prime to the same effect.

On top of this, in the long list of Wine errors that appear in the game log (unfortunately, this is always the case with programs that run in Wine, so it’s hard to tell which error messages are real errors) this is repeated many times, seemingly at the time of the program “hanging”:

[0212/222730.457:ERROR:] Exiting GPU process due to errors during initialization
[0212/222730.883:ERROR:] EGL Driver message (Critical) eglInitialize: No available renderers.
[0212/222730.883:ERROR:] eglInitialize D3D11 failed with error EGL_NOT_INITIALIZED, trying next display type
[0212/222730.940:ERROR:] EGL Driver message (Critical) eglInitialize: No available renderers.
[0212/222730.940:ERROR:] eglInitialize D3D9 failed with error EGL_NOT_INITIALIZED
[0212/222730.940:ERROR:] GLSurfaceEGL::InitializeOneOff failed.

The game is the only reason I need graphical environment on this laptop. I’ll easily sacrifice any other program / install DM from the 90’s to get things working. So, I wouldn’t care about that. Unfortunately, I simply don’t know what was installed prior to upgrade.

Moderator edit: Copied from Pastebin with proper formatting

I copied everything from your Pastebin into your post.

FYI, Discourse uses mostly Markdown and accepts some HTML, but not BBCode. :wink:

Please see: [HowTo] Post command output and file content as formatted text

Your profile says you’re on Stable branch. This branch still has the version of pixman (0.43.0-1) with debug features enabled, which causes these issues.

Testing and Unstable are at 0.43.2-1, where the upstream has retired debug features being tied to version numbers, and this issue goes away.
Until Stable gets up-to-date, your best bet is to downgrade the package.

Aside from whatever is going on with pixman I should point out that this isnt what you want.

Unless your BIOS supports disabling the iGPU then you will want to be using the hybrid profile.
Likely the latest one video-hybrid-intel-nvidia-prime.

You may or may not have realized how PRIME actually works … which by default would mean the iGPU normally, and the dGPU used if a command is prefaced with prime-run.

If you want to avoid that and use one GPU or the other … then you can use reverse-prime, or one of those utilities you mentioned. Though you probably want to avoid optimus-manager, and instead use envycontrol.

Also … I cant see the particulars here … but the BIOS looks old. Anything from recent kernels to recent drivers to security and performance may be impacted.

That’s where I started. Essentially, it was my mistake to buy a laptop with two GPUs. This is a completely unnecessary complication and works very poorly. To my defense, at the time I bought it, I had no idea such combos even existed, so, had no idea I had to look out for it.

I’ll have to investigate if the BIOS allows turning off iGPU, as I never needed it in the first place. I.e. I don’t want a hybrid, it’s an anti-feature for me. Subsequently, I don’t want a hybrid driver. I’ll take it only if there’s nothing else I can do about the situation.

Dear lord…

OK, sure, I’ll try downgrading and see where it goes. Sorry, I’ll have to do it probably on the weekend. Just wanted to say thanks for the replies.

Thanks. I saw that the quote tag was automatically generated in BB-style, just assumed everything else follows suite.

I used AUR (en) - downgrade to downgrade pixman and things are looking good so far.

Thanks for the help!

Stable has the newer version now, so this issue should be solved.