Rebuilt system won't boot after being dormant for 2 years

that is normal - and you seem to be where you need to be

that is also normal in the case your /home partition is on a separate partition - one of the 3 others, which was not mounted due to this simplistic method of booting the system


Now you can repeat the process - but instead of appending
you simply append a “1” (without the quotes)

the system should then boot fully - but only to a TTY

then you can proceed to attempt to repair your system
like @brahma said

It is actually not difficult - but you lack the background knowledge and “spatial awareness” and do not know what each command is doing and where you are after each step.

chroot is a simple matter of typing_
manjaro-chroot -a
once you booted from your CD or USB and have attached(mounted) your / partition

It puts you in the same place as the other method earlier described.

With both methods you end up in a TTY and have to use the command line to repair your system.

use it to recover your data if there are any
and then use it to re-install
… far easier and way faster …

Holy sh** I was able to get into tty on the main system drive.

Unsure how to proceed at this point, because the bootable usb I made seems to have given up the ghost after the first attempt. I booted into BIOS and boot options showed four choices for the usb (two for USB Boot and two for UEFI USB Boot). I selected what looked like the logical two choices, and then set the manjaro dvd for the next boot options. When I exited, it did the same as when trying to boot to the old system drive, i.e. a black screen. I just hit the reset button to see if changing the boot options would change anything, but now the BIOS doesn’t see the usb drive. I tried reformatting it and re"burning" the iso image and BIOS still doesn’t see the usb. Really frustrated by that.

So, anyway, being that I am now booted to the system disk, can I run the sudo command suggested by @brahma, as he (or you, brahma, if you’re reading) typed it? Or is it preferable to exit, reboot to the live dvd as you instructed (appending “1” to the command line), and run the sudo from there?

EDIT: @Nachlese looking at the Linux Techi page you linked, under " Step 1) Reboot Arch Linux & Interrupt booting", it says to “go to the grub boot loader screen”. But when I boot to the system disk (i.e. not the live dvd), I don’t get that option because it just black screens. I got in by following @brahma 's guidance of pressing ctrl+alt+f2 which takes me to tty. So unless there is a way to somehow do that command line edit, then I guess I have to exit and boot to the live dvd. Or should I just ignore that Linux Techi page at this point?

Worst case, I suppose can just pull the old system disk, hook it up to my windows laptop and put a fresh install on it. Then put it back and see if it will boot. Is there a windows software which will let me look at the disk so I maybe won’t have to wipe it? After writing the ISO to the usb, File Explorer no longer saw it.

Yeah, that’s basically what I meant by “degree of difficulty”. Everything becomes easier with experience.

I have to know…after spending 15 minutes reading this entire thread…What was the data on your old system that you went through all this trouble to try and recover? Please tell me you didnt do this for fun…

1 Like

what, you jelly? :clown_face:

1 Like

if you can enter into tty then run a full system update, which would be probably pointless because you have such old system:
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

did you install ventoy onto your usb and then copy the iso there?
did you disabled secure boot in bios and fastboot in windows?

… yes, since your board is new, you probably should revisit some default settings, like secure boot …

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

a topic can’t stay open for half a day?
let him try if he wants to …

Why does it need to be closed/finished now?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.