Really laggy, like it uses 1% CPU

My arch friend recommended me to make this post since he couldn’t figure it out.

Before I switched to Manjaro I had tried debian mint. It ran fine but it lacked the necessary drivers and my friend convinced me to switch to Manjaro. But during usb boot load I noticed there were significant lag which I initially thought was because of my flash drive but it persisted even after installation. Since then I’ve followed my friend’s recommendation of creating a swap, checking my ucode was up to date, updating my mesa driver, and changing to gnome, to no avail.

Significant lag(1 fps) has not been the only symptom, occasionally my screen has also glitched and froze. It has also in general been unresponsive with some application taking a lot of time to open. My computer is newly bought and my system info is this:

  Kernel: 6.1.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=a94d0934-25a5-4d93-9073-22d48001a6f0 rw quiet splash
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82UT v: Yoga Slim 7 Pro 14IAH7
    serial: <superuser required> Chassis: type: 10 v: Yoga Slim 7 Pro 14IAH7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76463 WIN
    serial: <superuser required> UEFI: LENOVO v: KRCN10WW date: 08/02/2022
  ID-1: BAT0 charge: 37.7 Wh (61.1%) condition: 61.7/61.0 Wh (101.2%)
    volts: 15.7 min: 15.4 model: Sunwoda L19D4PH3 type: Li-poly serial: <filter>
    status: discharging cycles: 3
  RAM: total: 15.35 GiB used: 1.96 GiB (12.7%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i5-12500H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x424
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB L2: 9 MiB
    desc: 4x1.2 MiB, 2x2 MiB L3: 18 MiB desc: 1x18 MiB
  Speed (MHz): avg: 2613 high: 3100 min/max: 400/4500:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3100 2: 518 3: 3100
    4: 3100 5: 520 6: 3100 7: 3100 8: 3100 9: 3100 10: 3100 11: 3100 12: 3100
    13: 482 14: 3100 15: 3100 16: 3100 bogomips: 99568
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid
    rdrand rdseed rdtscp rep_good sdbg sep serialize sha_ni smap smep smx
    split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes
    vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-8:2 chip-ID: 04f2:b756 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2880x1800 s-dpi: 96 s-size: 762x476mm (30.00x18.74")
    s-diag: 898mm (35.37")
  Monitor-1: eDP-1 model: AU Optronics 0xc391 built: 2020 res: 2880x1800
    hz: 90 dpi: 243 gamma: 1.2 size: 301x188mm (11.85x7.4") diag: 355mm (14")
    ratio: 16:10 modes: 2880x1800
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Sound API: ALSA v: k6.1.19-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:3
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 15.16 GiB (3.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: CRTP1311 temp: 29.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%) used: 15.16 GiB (3.3%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: a94d0934-25a5-4d93-9073-22d48001a6f0
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 4.4 MiB (1.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: A4C1-748C
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 3 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-8:2 info: Chicony Integrated Camera type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b756 class-ID: fe01 serial: <filter>
  Device-2: 3-10:3 info: Intel type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 301 Uptime: 15m wakeups: 191 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1277 libs: 352 tools: gnome-software,pamac
  pm: flatpak pkgs: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.25

Thanks in advanced.


Ok fixed! For future people who may run into the same issue as me, try this:

  • Open up the terminal and write kate /etc/default/grub or on manjaro gnome you can do sudo gedit /etc/default/grub

  • At GRUB_CMDLINE_LINUX_DEFAULT inside the quotes, add parameter i915.enable_psr=0. You add a parameter by adding a space at the end of the text inside the quotes. Don’t remove anything(Although I did it the first time with plasma and it seemed fine but just in case don’t)

  • Save the file, update grub in terminal sudo update-grub and reboot. It should now work

I did this with both Manjaro Plasma and Gnome. For gnome it was extremely obnoxious since the screen flickered at every mouse movement but it fixed itself after changing the resolution to 1920x1200.

1 Like

Hi and welcome to the Forum :+1:

Can you explain more what you were doing when that happens, and if the 1FPS is from your camera or normal GFX card (eg Anything on your screen)

Hope in mean time there will be people who can assist you, cause it’s my bed time now…

It’s frame laggy in general, even at the login screen.

A random idea: maybe it’s related to power saving? Like too effective or effective when it shouldn’t be?

It could also be a hardware failure: they usually show as the hardware wears, but there is also a possibility to show very early on defective products.
Since you mentioned you already had the issue in liveUSB, you could try to rule this out by testing other live distributions.

I had similar issues when I tried endevourOS after Manjaro. Also it looks like my usb drive died so I’m gonna have to get a new one xd. I believe debian mint worked fine though.

All linux distro’s use the same software, just different versions, so that makes no sense…

did you tried with different kernels? with the 6.2 and 5.15…
disable baloo - system settings/file search and uncheck all options, click apply;
and try adding this parameter:
kate /etc/default/grub
and inside this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything, just add it to existing parameters, save the file, update grub:
sudo update-grub
reboot and test

1 Like

your cpu is in powersave mode. switch to performance !

1 Like

Well that seems to be the reality of it so make that what you will of it. I checked again by running debian mint on a usb drive and it does not have issues running smoothly(although my touchpad doesn’t work or my wifi). LDME 5 uses kernal 5.10 so it is an older version than what Manjaro has.

I did cpupower set -b 0 and it didn’t have an effect.

Unsure how to change kernal but disabling baloo and changing grub seems to have done the trick and now it runs smooth.

1 Like

please post the output of

cpupower frequency-info

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.