Razergeine not working

I went to go use the razergeine tool tonight but discovered it doesn’t work anymore because the openrazer-deamon fails to run.

when I run openrazer-deamon from terminal I get this message

  File "/usr/bin/openrazer-daemon", line 11, in <module>
    from openrazer_daemon.daemon import RazerDaemon, __version__
ModuleNotFoundError: No module named 'openrazer_daemon'

found this Import issue in openrazer-daemon · Issue #637 · openrazer/openrazer · GitHub where someone Did you rebuild the openrazer packages after the latest python update (3.6.something -> 3.7.something)? You can get a list what you have to rebuild with pacman -Qo /usr/lib/python3.6/site-packages/

So I’m guessing the 3.9 update messed it up. Since rebuilding worked for the asker there I thought 'ok I’ll install the git package of openrazer-meta` but still no luck.

I found another issue where the same thing was said but how do I rebuild all those packages? The output of that command for me is a long list.

Hi @LinuxLoverForever,

I have absolutely no idea if this will work, but it might. So it’s worth a shot IMHO.

Tr rebuild detector. It can be found in the repositories.

Install it with:

$ pamac install rebuild-detector

Use it with:

$ checkrebuild

Then, if it reports any packages, you can rebuild them with pamac. For example:

$ pamac build python-sentry_sdk

I hope this helps.

I think rebuilding in this sense means to reinstall all the python libs. I wish there was a command in pacman to do them all in one shot. I suppose I could write a script to do it (in python ironically) but if pacman could do it in a one-liner that’d be awesome.

Well, you can’t do any HARM by trying, can you?

I’ve seen all over the forum, the Python upgrade causing issues, so I’d still recommend trying it, at least. If it works, cool. If not, doesn’t seem that there’s any harm done.

Well, that’s according to me, anyway. :man_shrugging:

You misunderstood me I wasn’t doubting that that wouldn’t work I just didn’t want to have to to do that individually for a list of 20 or so packages. (which is what the output of that command gave for my whole system) I ended up fixing it by installing the git version of openrazer-meta and every dependency it has and then rebooting. Glad the aur has a rule to have the git version of every possible package because it came in handy this time.

I’m very glad it worked ou in the end!

1 Like

Something like this, maybe? You’ll need to install yay as pamac doesn’t have anything like the --rebuild / --rebuildall flag:

yay -S --rebuildall $(pacman -Qm | cut -d ' ' -f 1 | grep ^python)
1 Like

YES!! I knew it had to exist. I’ll save that command for the future. :heart_eyes: Thanks!!!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.