Raspberry Pi4: enable_uart=1 in config.txt gives a kernel panic

  • What device are you using?
    Raspberry Pi4 w/ 4 GB of RAM

  • What edition of Manjaro-ARM is installed? (eg minimal, server, etc.)
    19.10 (KDE/Plasma) ARM for Raspberry Pi4

  • When did you last run updates and reboot?
    I did not update the kernel yet. Still the same from the image is flashed on the SD.

  • What package contains the bug?
    Kernel for Rpi4 ?

  • Describe the bug the best you can. What where you doing when the bug happened?
    Activating the "enable_uart" option in the 'config.txt' file gives a kernel panic at the next reboot. Last message on screen is related to uart.

  • Any workarounds or known fixes?
    I tried to activate this uart option just like the configuration script (made for Raspbian) for my specific case does it. In the end, after some tweaks (installing python packages, loading i2c_dev module, adapting the scripts, etc.), the software that controls the fan (and power button) works just fine without the "enable_uart=1" line in the configuration file.


Hi there!

So, here is a report of my experience with this "enable_uart" option in config.txt.
I'm not sure what the problem is (maybe uart is activated by default in Manjaro's kernel?) - in the end, it looks like this option is not needed anyway.

Maybe something could be done to avoid the kernel panic ?

Regards,
nibheis

That is correct but it is the RPi kernel in reality. The enable_uart=1 is used in the mainline kernel in config.txt.

Forum kindly sponsored by