Raspberry Pi Rotation is failing

Using the latest Manjaro version for Raspberry Pi 4 (64 bit mode). I changed I added display_rotate=3 in config.txt and its result is a misplaced screen. Is it possible to fix it?

With the RPi 4 the screen rotation is handled with xrandr.

DISPLAY=:0 xrandr --output HDMI-1 --rotate left 
DISPLAY=:0 xrandr --output HDMI-1 --rotate inverted
DISPLAY=:0 xrandr --output HDMI-1 --rotate normal

If your monitor does not show up correctly (say shows up as default and no way to configure anything in the Monitor Settings) then you probably have not disabled fbturbo. You need to do that first and reboot:

cd  /etc/x11/xorg.conf.d/
sudo mv  99-fbturbo.conf  99-fbturbo~

Then install some programs:

sudo pacman -S libxrandr autorandr xorg-xdpyinfo

I have the latest kernel with the new device naming conventions so my command would be this:

DISPLAY=:0 xrandr --output HDMI-1 --rotate right

Yours could be different if you do not have the latest and your cmdline.txt has not been manually modified so run xrandr and adjust the --output to what xrandr says. See pic below.

Screen rotated:

Forum kindly sponsored by Bytemark