Raspberry Pi Official 7" Touchscreen Displays Black Screen

kde
bug
manjaroarm
screen
raspberrypi

#1

When I use Manjaro ARM kde 18.12.1 with the official Raspberry Pi Touchscreen and a Raspberry Pi 3 b+ the screen shows the boot sequence and then displays a black screen where Manjaro would normally show the login screen.

I know that the touchscreen works and is plugged in correctly because when I boot into the latest version of Raspbian the touchscreen works perfectly.

I’ve also tried updating the firmware using sudo pacman -Syu which seems to make no difference in the touchscreen issue.

Normal hdmi output seems to work properly, and I suspect that the hdmi output is still being used by the Pi even when no monitor is plugged in to it.

Any help would be appreciated!
I am also relatively new to Arch Linux so please forgive me for overlooking anything obvious.

Thank you!


#2

I suspect you would have to edit the config.txt to match your touchscreen. By default it’s set to HDMI.


ODROID HiFi Shield 2 not detected as soundcard (ODROID C2)
#3

Perhaps it is just something you have to adjust in KDE.
Plug in your Monitor and go to system-settings. There you can choose what your primary display is.


#4

This is hard to do without a screen/picture to begin with… :stuck_out_tongue:


#5

If you run KDE on your pc, you probably could run systemsettings5 after X11-forwarding with ssh -X user@host into your rpi

https://wiki.archlinux.org/index.php/OpenSSH#X11_forwarding


#6

@Strit Sorry for the delay in my response.

I’ve tried a few things with the boot/config.txt file. Currently it looks like this:

enable_uart=1
# dtparam=audio=on
# hdmi_drive=2
# audio_pwm_mode=2
display_default_lcd=1

I commented the HDMI and audio related lines out to keep them from interfering with my configuration.

I also added the display_default_lcd=1 line which according to the Raspberry Pi documentation, “setting display_default_lcd=0 will ensure the LCD is not the default display, which usually implies the HDMI output will be the default” (https://www.raspberrypi.org/documentation/configuration/config-txt/video.md). This implies that display_default_lcd=1 will ensure the LCD is the default display (I am assuming that the 0 or 1 is read as a boolean). However, when I tried this there was no difference.

In addition to these changes, I attempted adding the line ignore_lcd=0 which fixed this type of issue in older versions of Raspbian with older models of Raspberry Pi. However, this only turned off the HDMI output when I tried it (no difference in the touchscreen), resulting in me having to burn the operating system to the micro-SD card again.

I’m going to try @rexmalcolm’s idea next.


#7

I just tried going to ‘Displays’ in System Settings with both an HDMI monitor and the touchscreen are plugged in, and the other monitor isn’t being shown as an option when I click on the Primary display drop-down menu.

I’m going to try @flipper’s idea next where I ssh onto the Pi to change the settings without an HDMI monitor plugged in. (I’m going to use a vm to do the ssh because I don’t have Manjaro on my computer right now.)


#8

You will need to enable SPI support, I would try the LCD Module and Touch controller part explained here