Raspberry Pi Kernels (2.0)

ha, keyboard repeat not just ‘a’ key, sorrrrrrrrrrrrrry.

Thank you Darksky for the detailed description of the kernels.

I am currently using linux-rpi5 6.6.20.1, which is proving to be great for my purposes (multi-media device connected to TV and Hi-Fi). Has not crashed once when using plasma on X11,

These latest kernel updates has been pushed to the unstable branch when the mirrors sync.

There has been some major changes with these kernels. RPi has officially moved to the 6.6 LTS kernel as their stable kernel. They have also added 3 more RPi devices:

bcm2712-rpi-cm5-cm4io
bcm2712-rpi-cm5-cm5io
bcm2712d0-rpi-5-b

I do not have any of these new devices to test. Due to circumstances at this time not under my control there is no image at this time for these new devices. The first time there will be an image will be the DEV image that gets built each Monday here. It will be named Dev 20240311

https://github.com/manjaro-arm/rpi4-images/releases

New kernels pushed:

linux-rpi4 6.6.21-1
linux-rpi4-headers 6.6.21-1
linux-rpi5 6.6.21-1
linux-rpi5-headers 6.6.21-1
2 Likes

about images, maybe add LXQT for lighter QT6/wayland option?

Kernel v6.7.9 is out

This is off-topic should be here: Additional ARM Packages

Kernels v6.8.1 and v6.7.10 are out

6.8.1, no one had keyboard repea…t issue?

The new linux-rpi4-rc-6.9.rc1-1 / linux-rpi5-rc-6.9.rc1-1 kernel packages pushed to the unstable branch when mirrors sync.

Kernel v6.8.2 is also out.

does plasma-0311 img build is 6?

Hey Rip2,

I tried running all the images from the 20240311 release on my RPi5, including the Plasma image (0311 still KDE 5.10) but couldn’t get any of the GUIs (GNOME, KDE, XFCE, Mate) to start up. Seems like there might be something off with the image build script. Not sure if it’s just me or a wider issue, which is why I’ve created a help thread looking for help.

Could you give it a shot too?

don’t have Pi5, and don’t want one(old gcc etc, issue).

RPi kernel related packages pushed to the unstable branch:

linux-rpi4 6.6.23-1
linux-rpi4-headers 6.6.23-1
linux-rpi4-mainline 6.8.2-1
linux-rpi4-mainline-headers 6.8.2-1
linux-rpi5 6.6.23-1
linux-rpi5-headers 6.6.23-1
linux-rpi5-mainline 6.8.2-1
linux-rpi5-mainline-headers 6.8.2-1
raspberrypi-bootloader 20240327-1
raspberrypi-bootloader-x 20240327-1
rpi-overlays 20240327-1
1 Like

6.9-rc1 seems fix keyboard repea…t issue, after week test.

See what -rc2 does when the mirrors sync…

Chromium crash only with 16k kernel, not 4k. At least in gnome.

chromium 
[147585:147585:0404/002252.820435:FATAL:zygote_host_impl_linux.cc(201)] Check failed: . : No such file or directory (2)
Trace/breakpoint trap (core dumped)

Is it possible not to remove kernel=kernel8.img from the config.txt file every time, as raspios does? But to put an informative message in the config file, giving people the choice of activating 4k or 16k, at the expense of memory efficiency of around 8%, but with the possibility of using wine, dosbox, waydroid…

v6.8.4 is out

Done. Starting with these kernels pushed to the unstable branch today. 6 months is long enough time for users to upgrade their packages to accommodate for the pi5. I realize it is a pain to re-do custom configs.

linux-rpi4 6.6.25-1
linux-rpi4-headers 6.6.25-1
linux-rpi4-mainline 6.8.4-1
linux-rpi4-mainline-headers 6.8.4-1
linux-rpi5 6.6.25-1
linux-rpi5-headers 6.6.25-1
linux-rpi5-mainline 6.8.4-1
linux-rpi5-mainline-headers 6.8.4-1
raspberrypi-utils 20240402-1
rpi-overlays 20240405-1
1 Like

4k & 16k, but kernel patches not merge yet?
https://lore.kernel.org/dri-devel/20240405201753.1176914-1-mcanal@igalia.com